WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Gravity Forms Salesforce Add-on] Fatal error: Class SoapClient not found

[Resolved] [Plugin: Gravity Forms Salesforce Add-on] Fatal error: Class SoapClient not found

Viewing 6 replies - 1 through 6 (of 6 total)
  • I got this same error. On a Dreamhost shared hosting account, it was fixed by changing the PHP version on the site from v5.2 to v5.3 – I guess they included SoapClient by default in their v5.3 builds, but not v5.2.

    How you add it if it’s not built-in by default on your host is going to depend on the host, the version of PHP your site is currently running, and the amount of access you have (shared hosting, VPS, dedicated, etc.) Forms -> Settings lists your current version numbers for PHP, MySQL, WP and GF at the bottom (why isn’t this in the normal WP admin interface?!)

    brasofilo

    @brasofilo

    I ended up changing hosts and the culprit was exactly that: PHP 5.2…

    Thanks for the input!

    Plugin Contributor Zack Katz

    @katzwebdesign

    I’ll add a compatibility check on the next update. Thanks for reporting!

    I am running 5.3.17 and I still have this issue?

    I had to install the soap directory in my php build. I did this in WHM

    Ahh I do not have the right version of salesforce for (API access) this should be specified 🙁

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms Salesforce Add-on] Fatal error: Class SoapClient not found’ is closed to new replies.