WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Gravity Forms Salesforce Add-on] Custom fields are not populating

[Plugin: Gravity Forms Salesforce Add-on] Custom fields are not populating

  • axiomuser

    @axiomuser

    Using version 1.1
    I have followed all of the steps in the FAQ section and am sure that I have the correct API names put in the parameter fields in my forms. This did not send the information to SF. I then deleted these and added the API names to the Admin label. Custom fields were not sent to SF. So, I then added the API names to both the parameter and Admin label fields, and nope. I then thought that maybe because the field names are changed to numbers like this = <input name=”00N40000001pQbU” type=”text” id=”00N40000001pQbU” value=””> that the admin values should be set to “00N40000001pQbU” as that is what SF thought should be the field name, and that didn’t work.

    I would love, need, to get this to work. At this point I will pay anyone who can make this work. If you have a solution, or want the work, contact me at peter@agdsweb.com . Yes, this is a cry for help.

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

Viewing 15 replies - 1 through 15 (of 21 total)
  • TeamKaeru

    @teamkaeru

    Did you ever get this working? I have used Gravity Forms *without* the salesforce plugin to get things up and running including custom fields, so that may be an option for you, too.

    axiomuser

    @axiomuser

    I never did. If you could offer some assistance that would be great.

    TeamKaeru

    @teamkaeru

    Sent you an email with three options. Of course with free advice you get what you pay for, haha 🙂 But hopefully it will send you in the right direction. The same thing was making me a little nuts, hence I found this post! If that doesn’t help get you going, I can probably look at what you’ve got goin’ on… Let me know how it goes!

    @teamkaeru – would love to hear your suggestions, as I’m going nuts with the same issue. PLEASE email me if you don’t mind! jeb [at] actorsfoundry [dot] com

    thank you!

    I am having the same problem with the custom fields as well. Would also love to see if anyone has figured this out. Thanks! Please e mail me at dfionda [at]candeos [dot] com Thanks!

    I dont know if this is relevant, but I just got a custom field to work What I was doing before was using a URL field type in Gravity and the SF field type was text. I changed it and got it to populate.

    Dave

    Also, I found out that you cannot name the field anything other than the fieldname in SF. The field label in GF must match the custom field label in SF

    Also, the plugin does not like spaces in the SF field names. I put in a field No. of Partners, and it didn’t work. I changed it to Partners and it worked like a charm.

    Hope this helps!

    @candeos thank you for your suggestions – tried them all and STILL not working. Ugh.

    One question for you: are you using the SF Field API or the SF Field Label in the ‘Advanced’ section of GF, and are you providing the info in ‘Admin Label’, ‘Parameter Name’ or both?

    thanks again for your info!

    @candeos – also, re your field type change – did you change GF type to text or SF type to url?

    I just made sure the field types matched.

    Dave

    I am having a similar problem. I have been able to get some custom fields to populate, but not all. There doesn’t seem to be any rhyme or reason for it. The issue seems to be more with address and telephone fields than others. I even have one field that will populate the second line of the standard address field.

    I have high hopes for this plug in as it would really help my workflow, but it just doesn’t seem to want populate all of the custom fields.

    I think I may have figured out part of the problem. The custom fields that either aren’t populating in Salesforce or that are populating in the wrong spot seem to be address or telephone number fields. If I change the field type in Gravity Forms to Single Line Text and remove all references to address, or telephone number from the Field Label, Admin Label and Description, they will populate.

    I don’t know why the problem occurs when the Field Label, Admin Label and/or description contain the words “address” “city” “state” “zip” or “phone” but it is preventing them from populating.

    I quit.

    thanks y’all for sharing your suggestions and experiences. I’m officially waiting for a solution from the developer. workaround with the email of the completed gravity form with a half-popluated SF lead is a good start and still keeps things running more smoothly, so will have to do for the time being.

    Katz! please let me know if i’m missing anything here!

    Plugin Contributor Zack Katz

    @katzwebdesign

    I’ll have a solution by the end of this week – I’ve been busy, but reading this thread. Sorry for the issues.

    Thanks Zack, much appreciated!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Gravity Forms Salesforce Add-on] Custom fields are not populating’ is closed to new replies.