WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Gravity Forms Highrise Add-on] Not transferring to Highrise

[Plugin: Gravity Forms Highrise Add-on] Not transferring to Highrise

Viewing 14 replies - 1 through 14 (of 14 total)
  • Having issues as well! Please advise.

    Nothing is being sent to highrise.

    http://austincountertops.com/contact

    Thanks!

    Jackson

    I am on shared hosting with network solutions. The API token and url both check out fine. When I submit though, the entry is not submitted to highrise.

    It seems the issue is that the request variables are not being parsed at the correct time.

    This is the array I have on pushContact:


    Array ( [sFirstName] => [sLastName] => [sBothName] => [sCompany] => [sTitle] => [sEmail] => [sPhone] => [sMobile] => [sFax] => [sCity] => [sCountry] => [sState] => [sStreet] => [sZip] => [sWebsite] => [sSubject] => [sNotes] => [sTags] => [highrise] => [sBackground] => [sTwitter] => ) Array ( [sFirstName] => [sLastName] => [sBothName] => [sCompany] => [sTitle] => [sEmail] => [sPhone] => Phone [sMobile] => [sFax] => [sCity] => [sCountry] => [sState] => [sStreet] => [sZip] => [sWebsite] => [sSubject] => [sNotes] => test from contact form [sTags] => [highrise] => [sBackground] => [sTwitter] => [REQUIRED] => [First Name] => Jackson [Last Name] => Blacklock )

    None of the s prefixed parameters are being created. So:


    <first-name>'.htmlspecialchars($request['sFirstName']).'</first-name>
    <last-name>'.htmlspecialchars($request['sLastName']).'</last-name>

    Ends up empty.

    Is the getLabel function not working correctly?

    I’ll keep checking around.

    Cool, so I found that I had to use the name type field because for some reason the first name or last name labels were not being detected.

    I then found an issue with not passing email and phone to highrise. gform is returning both email and phone as an array in $field[“inputs”] so I needed to parse phone and email as an array instead of a single-input.

    The last issue is any other form value… which is not being passed as a note.

    Word.

    jx

    I have updated the plugin to submit all params just fine…. for me. But it does not submit the entries to highrise for anyone else? Is that some cookie or auth issue?

    Thanks,

    Jackson

    This is a killer plugin! Some great work. Just curious if it’s something that highrise has changed with their endpoint because the performance is a bit spotty.

    I just need some idea as to whether or not other folks are experiencing any problems with it.

    Thanks,

    Jackson

    bettylocal

    @bettylocal

    Jackson, et al:

    Yes, I am experiencing problems. And I’m totally bummed here b/c I previously had a smooth functioning system! However, I just updated to the most recent versions of a) WordPress, b) the Gravity Forms Plugin, and c) the Gravity Forms Highrise Add-on. And now my data is not presenting in Highrise.

    Help?

    jhblacklock

    @jhblacklock

    Yup.

    So I had to modify the plugin to get it to work… although mine is quite specific to the site it is working nicely.

    See if you can change the debug flag in HighriseAPI.php (request function) to true, submit the form, then post what prints out in the browser, that will give you a great idea of what’s going on.

    View the source and copy the xml that’s being sent too.

    The guys at highrise recently modified the api so there might be a few hiccups.

    -Jackson

    So this is not working now? I can’t get it to work and I have really tried.

    I can’t get it to work either:
    GF – Version 1.5.3
    Gravity Forms Highrise Add-On – Version 2.4.3
    WP: Version 3.2.1

    API and URL passes.

    Tried Text field names as first, last
    Tried name field with separated first / last

    Does not post to Highrise… Help guys?

    Hi all the author of this plugin states it works with WP versions up to 3.1.4. Im installing a previous version to see if this is causing the problem for some reason.

    That was the issue, or perhaps due to the gensis framework. I was able to get this to work with a fresh install of:

    GF – Version 1.5.3
    Gravity Forms Highrise Add-On – Version 2.4.3
    WP: Version 3.1.4

    Hi, is there a file in the plug-in that could be modified to send data to a different (not as popular as Highrise or Salesforce) CRM?

    hi, its not working for us either, we are using WP 3.1, gravity forms 1.6.2, highrise addon 2.4.3 –

    do we really have to downgrade to GF 1.5.3, and upgrade to WP 3.1.4 to get this to work??? is that the majic numbers? that would be very sad…

    Not working here either. I’ve enabled the plugin, I’m using wp 3.2.1 and the latest version of the plugin, set the url and api, checked the highrise integration on gravity, and NOTHING.

    New contacts never make it to Highrise.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Gravity Forms Highrise Add-on] Not transferring to Highrise’ is closed to new replies.