WordPress.org

Support

Support » Plugins and Hacks » Gravity Forms eWAY » [Resolved] [Plugin: Gravity Forms eWAY] Eway Customer Address

[Resolved] [Plugin: Gravity Forms eWAY] Eway Customer Address

  • Since updating to V1.2 the customer detail address section over on eway seems to be inserting a 0.

    For example a customer enters address 5 Smith Street in the address line of the gravity form and this gets stored in the entry ok but over one eway it has

    0, 5 Smith Street

    When the address field is hidden by conditional logic on the form over on eway the address I would expect to be blank but it contains a solitary 0

    Looking back at old transactions before upgrading the address seemed fine.

    Strangely using the same form on a test enviroment (iis / wamp) and the eway sandbox I can’t recreate it but it is happening for all real transactions on the live site. (maybe enviromental php version or something ?)

    Not sure if it is relevant but I am hiding country, state/region and address line 2 in my gravity form and also using filters to change the labels Address Line 1 to Street Address, City to Suburb and Zip to Post Code.

    There has been no other changes on the live site other than this upgrade to the eway plugin and I am not aware of eway making any change ?

    Any idea what may be causing this ?

    http://wordpress.org/extend/plugins/gravityforms-eway/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author webaware

    @webaware

    G’day Steve,

    I changed the way I’m concatenating those fields, and it appears that it causes some problems on PHP < 5.3. I made the change when adding support for recurring payments, which wants those fields kept as separate components.

    I’ll get a new release out tonight with a fix. Thanks for reporting the bug.

    cheers,
    Ross

    Plugin Author webaware

    @webaware

    G’day Steve, the new release is up now so please give it a burl and let me know.

    cheers,
    Ross

    Hi Ross,

    This updated version seems to have done the trick. My host has PHP 5.2.17 installed and it now works fine.

    Thanks for the quick fix.
    Steve

    Plugin Author webaware

    @webaware

    No worries, glad it’s sorted now.

    cheers,
    Ross

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms eWAY] Eway Customer Address’ is closed to new replies.
Skip to toolbar