Support » Plugins and Hacks » Gravity Forms Directory » [Resolved] [Plugin: Gravity Forms Directory] Date picker conflict

[Resolved] [Plugin: Gravity Forms Directory] Date picker conflict

  • I’ve tried several events calendar plugins, and they all have the same problem: the date picker does not pop up properly and I can’t enter a date. When I disable Gravity Forms Directory, the date picker works fine. Is anyone else having this problem and do you have suggestions for resolving it? The theme is the default right now, and changing themes doesn’t alter the issue.
    I really need both of them to work!
    I can post screenshots but the issue is only visible on the backend, so linking the site won’t help.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Zack Katz


    Where is the date picker not working? I assume the Edit Form page?

    The date picker works fine in your plugin but it does not work in any of the 4 event plugins I’ve tried, and it looks the same in all of them. When I disable the Directory plugin, the date pickers in the event plugins work fine.

    Plugin Author Zack Katz


    Where do the date pickers work or not work?

    I have the same issue with WP Events Manager, when I disable “Gravity Forms Directory & Addons” it works again.

    Any solution to having them both active?

    Plugin Author Zack Katz


    This will be fixed shortly. Thanks for reporting!

    Hey Zack,
    Any idea when we’ll have a bugfix for this?

    Is there a way to make it work until it is updated?




    It appears Gravity Forms Directory is breaking my WordPress also. When it is enabled I cannot edit a page. When I inspect for errors in chrome I can see this

    Uncaught TypeError: Object [object Object] has no method 'datepicker' post.php:912
    (anonymous function) post.php:912
    e.extend.each load-scripts.php:2
    e.fn.e.each load-scripts.php:2
    (anonymous function) post.php:900
    o load-scripts.php:2
    p.fireWith load-scripts.php:2
    e.extend.ready load-scripts.php:2
    c.addEventListener.B load-scripts.php:2

    So it appears to be the datepicker for me also. Any word on when this might be fixed?




    I agree with Chrislawson.

    I also have the same problem with

    Uncaught TypeError: Object [object Object] has no method ‘datepicker’

    in post-new.php

    I can’t insert media files or use any of the “buttons” in the wysiwyg editor.
    Also all the “buttons” in the editors html view is gone.

    I’m also not able to edit status and publicity…..

    Plugin Author Zack Katz


    Thanks for the help debugging – this should be fixed in version 3.3.1 (just uploaded) – please let me know if it’s not.



    Great job Zack. It seems like it’s working.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms Directory] Date picker conflict’ is closed to new replies.