Support » Plugin: Gravity Forms Directory » [Plugin: Gravity Forms Directory & Addons] Search not displaying any results?

  • Hello –

    Thank you for this awesome plugin!

    I’m having problems with the search box. I added a bunch of test entries and even made sure entries were paginated (if that’s what the problem was)… but any time I search it just says “This form does not have any entries yet.”

    Basically one of the columns is “State”… I have a bunch of test entries with CA, NY, MT, etc…

    And when I search “CA” it doesn’t display those results.

    Thank you!!!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Having the same Problem. Did you find a solution? Anyone get the search to work?

    Plugin Author Zack Katz

    (@katzwebdesign)

    Have you tried the search in the backend using the search field in the top-right of the Entries page? If so, does it return results?

    It returns results if approved=”false”, but not if approved=”true”, even if all entries have been approved by the admin.

    Just re-read your question and think I misunderstood. To clarify my answer:

    Yes, the results are found when the back end is searched, but in the front-end user interface, search results are returned only if the approve function is set to false.

    Plugin Author Zack Katz

    (@katzwebdesign)

    Ah, thanks that’s helpful.

    I’ll be working on an update to the plugin to address this and other issues next week.

    Zack, before I go and attempt to recreate the wheel, are there any formatting updgrades to be included in the update?

    Thanks for the replies!

    lolawson – I haven’t found a solution yet.

    Zack – Thank you for looking into this! =)

    I’m having this same issue. Any word on when the udpate will come out?

    Plugin Author Zack Katz

    (@katzwebdesign)

    It’s almost ready to go. Should be out tomorrow.

    Thanks, Zack, for your prompt reply. =) Looking forward to it!

    Plugin Author Zack Katz

    (@katzwebdesign)

    Hi,

    We are using the most current version; however, the frontend search for the directory is not working for us. Searching for a valid keyboard appearing in the directory still returns “This form does not have any entries yet.” even when the searched entry is approved or unapproved.

    Has anybody encountered this issue with the current version and/or have any suggestions/solutions?

    Thanks in advance.

    Sorry, I meant “keyword”, not “keyboard”

    Hi I’ve retested again and noticed that if the directory is set to approved=”false” then sometimes the search keywords return entries; however, this is not always, especially when some multiple word keywords are searched (e.g. my org) that do match some entries.

    If approved=”true” then there are never any results returned, even if there are actual matches.

    I tried the backend admin directory search at http://www.mysite.com/wordpress/wp-admin/admin.php?page=gf_entries&view=entries&id=1 and it seems to work fine, even with multiple word keywords. It just doesn’t work on the frontend.

    Any ideas/suggestions? Is anybody still encountering this issue too?

    I’m having this issue also, with the exact same details. I have approval=”true” and no results in the front end with any search =( It’s too bad, as everything else is working great…and I’m asking for it to do a lot!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Gravity Forms Directory & Addons] Search not displaying any results?’ is closed to new replies.