Support » Plugins and Hacks » [Resolved] [Plugin: Gravity Forms Directory & Addons] output not displaying and can't approve entries

[Resolved] [Plugin: Gravity Forms Directory & Addons] output not displaying and can't approve entries

  • Just downloaded the update to the plugin and the directory output isn’t displaying. I’ve tried uninstalling the plugin and reinstalling, but that didn’t work.

    I tried reinserting the directory short code into the relevant page and was sure to uncheck the box to display only approved entries, still didn’t work.

    Also, I am unable to approve entries. When I click the red X next to an entry, it changes to the green check mark, but if i navigate away from the entries page and come back, it’s back to being a red X.


Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author Zack Katz


    You can still manually approve entries by editing each entry and checking the Approved box. (I’ll look into this, but I’m heading out for the weekend…)

    Yup, ive got exactly the same problem. Can you make v2 available to download as a temp fix to roll back to?
    Cant manually approve the entry’s. Getting errors all over, some fatal.

    Hi Zack, thanks for responding. Unfortunately, there is no option when editing each entry to manually approve it. As neo suggested, can you make previous version available in the meantime?

    Plugin Author Zack Katz


    You need to make sure you have an “Approved” form field. Try adding a new Approved field from the Directory Fields box in the Form Editor.

    Also, try using Chrome or Firefox or Safari and see if that helps. I haven’t tested on Internet Explorer.

    Same problem. The Approved form field is empty and just shows as a No title field. The checkbox that I see in the video is not there.

    I’ve amended self::get_lead_table_name() to RGFormsModel::get_lead_table_name() and the form displays now but still with no entries, and I get the following error when trying to approve any entries:

    Warning: Invalid argument supplied for foreach() in /home/redhouse/public_html/wp-content/plugins/gravity-forms-addons/gravity-forms-addons.php on line 1739

    Still cant approve anything, and the “approve” field is empty when you select it in the form editor (nothin under “properties”, “advanced” or “directory” and you can’t even edit the “Untitled” title.

    I love the plugin but I’m thinking this version need a little more work before it’s relaunched?

    I am also having several problems with the lastest version. All entries in a directory that had been published with the previous version disappeared after upload and I did have an “approved” field created and checked.

    When I attempted to rebuild the directory using the icon on the page editor tool bar, there was an error and no response to clicking on the “insert directory” button. I then tried hand typing the directory code onto page again and all entries, marked approved still did not appear.

    Having similar issues as above with the adding of the approve field on a new form with new directory tab. Using the checkbox button on the standard field tab for an “approved” field will still not return entry results in a directory that requires approval.

    Plugin Author Zack Katz


    Thank you all for contributing to these bug reports.

    I’ve not been able to reproduce any of the issues except for the self::get_lead_table_name() issue.

    To help me fix these issues, could you please:

    • Make sure the errors exist while using Chrome, Firefox, or Safari browsers. The plugin has not been tested in Internet Explorer (“IE”).
    • If you experience IE-only issues, let me know they happen in IE and what version you’re using.
    • Make sure you’re running either Version or 1.6 beta of Gravity Forms.
    • Link to your sites’ directory pages.
    • Post any Javascript errors you may be seeing.


    I’m using Gravity Forms, error on Firefox 6.0.2…

    I’ll try deactivating each plugin I have one at a time to see if that changes anything and report back.

    Plugin Author Zack Katz


    Thanks, neo. I would really like to get this figured out for you and others who have this same issue.

    Hi Zack,

    I am using IE8 and Chrome, Gravity Forms, Gravity Forms Directory and Addons 3.0.

    I have same issues in both browsers. I rebuilt my form, made new entries and have same issues as noted. Will send my links separately. THANKS!

    Hey! I´m also using Gravity Forms and Safari. I´ve tried to disable all other plugins but same problem. I am however using wordpress multisite…

    Do you want to send links or admin login? If you do how could I send that privatly?

    @eigilsagafos – login would be very helpful. info@katzwebservices.com please.


    Tested v3 again with every plugin deactivated and although I see no specific error messages, I still can’t “approve” any entry. Whether I click to approve one by one or use the bulk approval (which shows the message “20 entries approved” but doesn’t change them to green ticks), the entries remain unapproved and don’t show up in the directory table.

    v2.5.2 works perfectly (but without the date range option that I need to run).

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms Directory & Addons] output not displaying and can't approve entries’ is closed to new replies.