Support » Plugin: Gallery - Flagallery Photo Portfolio » [Plugin: GRAND Flash Album Gallery] got a PHP warning and gallery not working anymore

  • moved to a new server and upgraded the gallery plugin to the newest one, now I find these warnigns and no gallery displays:

    [Wed Mar 16 11:47:41 2011] [warn] [client 87.178.225.142] mod_fcgid: stderr: PHP Warning:  include_once(): Failed opening '/var/www/clients/client4/web9/web/wp-content/plugins/flagallery-skins/default/default.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/clients/client4/web9/web/wp-content/plugins/flash-album-gallery/lib/swfobject.php on line 27, referer: http://www.021club.co.za/

    and in the gallery options there isn’t a single skin listed 🙁

    doesn’t the plugin come with a default skin?

    http://wordpress.org/extend/plugins/flash-album-gallery/

Viewing 8 replies - 1 through 8 (of 8 total)
  • deactivating and re-uploading the plugin fixed this. still got this error :

    [Wed Mar 16 11:54:02 2011] [warn] [client 87.178.225.142] mod_fcgid: stderr: WordPress database error Multiple primary key defined for query ALTER TABLE 021_flag_gallery ADD PRIMARY KEY gid (gid) made by activate_plugin, do_action, call_user_func_array, flagLoad->activate, flag_install, dbDelta, referer: http://www.021club.co.za/wp-admin/plugins.php

    and the upgrade to the latest version of your plugin now gives me a CSS issue:

    the gallery hides my dropdown in the last column 🙁

    see live here please: http://021club.co.za

    I can’t roll back to the latest version as I know the database structure had changed 🙁

    any advice please?

    regarding the hidden drop down I foudn a solution but I guess it needs implementing in your plugin, could you maybe please check:

    The Problem: You have a CSS based drop-down menu in your navigation and a flash element near it the menus may get “hidden” behind the flash object.

    The Solution: Set the z-index of the div holding the flash to 1 and the z-index of the div holding the nav to 2.

    In the flash element:

    Look for the flash <object> tag and add the following code:

    <param name=”wmode” value=”transparent”>

    You’ll want to insert this code right below the <param name=”quality” value=”high”> tag and include the code wmode=”transparent” in the flash <embed> tag .

    solved by taking away the choice between transparent and window:

    if(empty($wmode)) {
                            $wmode = $flashBacktransparent? 'transparent' : 'transparent';
                    }

    is there another fix for this?

    FlAGallery -> Skins -> Skin Options -> checkbox ‘transparent’
    If you don’t want background be transparent, then add style for .flashalbum class to your stylesheet:
    .flashalbum { background: #000000; }

    I am not sure I explained the situation very well, let me try again:

    THe gallery is shown below a drop down menu. If I hover over the menu, it drops down but the gallery hides it. the drop down menu drops down “behind” the gallery. by changing its z-level and this line:

    $wmode = $flashBacktransparent? 'transparent' : 'window';

    to this

    $wmode = $flashBacktransparent? 'transparent' : 'transparent';

    I got it to work. The drop down now drops down in front of the gallery.

    Thanks Ovidiu. That worked for me as well. Just wanted to mention that the line to edit is in the swfobject.php file.

    cool.
    Unfortunately I seemed unable to properly explain the problem to the plugin author. It would have been nice to have a “proper” solution…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: GRAND Flash Album Gallery] got a PHP warning and gallery not working anymore’ is closed to new replies.