WordPress.org

Forums

Grand Flagallery - Photo Gallery Plugin
[Plugin: GRAND FlAGallery - Best Photo Gallery] Flash uploader HTTP error 302 (4 posts)

  1. polynatiag
    Member
    Posted 2 years ago #

    Hi,

    When I try to upload screenshots through the flash uploader, I get HTTP error 302 and the files won't be added to my gallery. If I upload them manually through SFTP and try to search for new images, it does work. However, I would like to be able to use the Flash uploader as well.

    I tried this with a dummy account (subscriber) and Administrator account, so I'm pretty sure it isn't roles-related.
    I made a screenshot to make it clearer: http://i.imgur.com/551H3.png

    I hope you can help me with this.

    Thank you!

    http://wordpress.org/extend/plugins/flash-album-gallery/

  2. polynatiag
    Member
    Posted 2 years ago #

    I had a look at the serverlogs. This is what it looks like when uploading multiple images through the flashuploader:

    178.79.129.186 - - [29/Jul/2012:10:36:32 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550992.0006580352783203125000 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"
    my.own.ip.addr - - [29/Jul/2012:10:36:31 +0200] "POST /community/wp-content/plugins/flash-album-gallery/admin/upload.php?_wpnonce=7a8f49361f HTTP/1.1" 302 4456 "-" "Shockwave Flash"
    178.79.129.186 - - [29/Jul/2012:10:36:32 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550992.6297929286956787109375 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"
    my.own.ip.addr - - [29/Jul/2012:10:36:32 +0200] "POST /community/wp-content/plugins/flash-album-gallery/admin/upload.php?_wpnonce=7a8f49361f HTTP/1.1" 302 666 "-" "Shockwave Flash"
    178.79.129.186 - - [29/Jul/2012:10:36:33 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550993.1902339458465576171875 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"
    my.own.ip.addr - - [29/Jul/2012:10:36:32 +0200] "POST /community/wp-content/plugins/flash-album-gallery/admin/upload.php?_wpnonce=7a8f49361f HTTP/1.1" 302 666 "-" "Shockwave Flash"
    178.79.129.186 - - [29/Jul/2012:10:36:33 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550993.7031259536743164062500 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"
    my.own.ip.addr - - [29/Jul/2012:10:36:33 +0200] "POST /community/wp-content/plugins/flash-album-gallery/admin/upload.php?_wpnonce=7a8f49361f HTTP/1.1" 302 666 "-" "Shockwave Flash"
    178.79.129.186 - - [29/Jul/2012:10:36:34 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550994.2397060394287109375000 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"
    my.own.ip.addr - - [29/Jul/2012:10:36:34 +0200] "POST /community/wp-content/plugins/flash-album-gallery/admin/upload.php?_wpnonce=7a8f49361f HTTP/1.1" 302 666 "-" "Shockwave Flash"
    178.79.129.186 - - [29/Jul/2012:10:36:34 +0200] "POST /community/wp-cron.php?doing_wp_cron=1343550994.7389230728149414062500 HTTP/1.0" 200 4517 "-" "WordPress/3.4.1; https://obeygaming.com/community"

    Hopefully it'll help.

    Thanks again

  3. codeasily
    Inactive
    Posted 2 years ago #

    This is problem with your server settings or '/wp-content/flagallery/' folder does not have write permissions. Try chmod it to 755 or 777.

  4. polynatiag
    Member
    Posted 2 years ago #

    Hi,

    I did a recursive chmod 755 and 777 (tried both) on the flagallery directory - made no difference.

    You mention server settings, how can I troubleshoot that? It's running Apache with PHP-FPM/FastCGI

    I have the following Apache modules loaded:

    Loaded Modules:
     core_module (static)
     log_config_module (static)
     logio_module (static)
     mpm_worker_module (static)
     http_module (static)
     so_module (static)
     actions_module (shared)
     alias_module (shared)
     auth_basic_module (shared)
     authn_file_module (shared)
     authz_host_module (shared)
     cache_module (shared)
     cgi_module (shared)
     cgid_module (shared)
     deflate_module (shared)
     dir_module (shared)
     env_module (shared)
     expires_module (shared)
     fastcgi_module (shared)
     headers_module (shared)
     mem_cache_module (shared)
     mime_module (shared)
     evasive20_module (shared)
     negotiation_module (shared)
     version_module (shared)
     pagespeed_module (shared)
     reqtimeout_module (shared)
     rewrite_module (shared)
     setenvif_module (shared)
     ssl_module (shared)
     status_module (shared)
     unique_id_module (shared)

    I initially thought maybe it had something to do with the Pagespeed module, but disabling this had no effect, so it can't be that.

    Thanks,

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Grand Flagallery - Photo Gallery Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic