Support » Plugins and Hacks » [Plugin: Google XML Sitempas] Fatal Error at line 910 of sitemap-ui.php

  • Today I’m getting this after moving to a new hosting:

    var pages = [ <br />
    10<b>Fatal error</b>: Call to a member function getUrl() on a non-object in <b>/home/myhostm/public_html/wp-content/plugins/google-sitemap-generator/sitemap-ui.php</b> on line <b>910</b><br />

    And the plugin page is broken in the middle, I cannot access bottom options.

    Any idea why is this happening?

    forgot to put my wp version: 2.9.1
    plugin version: 3.2.2

Viewing 6 replies - 1 through 6 (of 6 total)
  • Please? Any idea on how to fix this?

    After 7 months I’m encountering this error again.

    The code involved of the plugin is:

    echo '{url:"' . $v->getUrl() . '", priority:' . number_format($v->getPriority(),1,".","") . ', changeFreq:"' . $v->getChangeFreq() . '", lastChanged:"' . ($v!=null && $v->getLastMod()>0?date("Y-m-d",$v->getLastMod()):"") . '"}';

    What I did was implrting the tables from another installation.

    Still no ideas? Everyone runs this plugin with no problems at all?

    First looks like you bumped your message when you first posted. Most people that answer regularly look for posts w/o replies.
    Second, have you tried disabling other plugins to see if there is a conflict?
    What version of WP? If still on the same vers. yu most definitly need to upgrade.
    WHat version of the plugin?
    Apache or IIS?

    Thank you for the attention.

    First time (8 motnsh ago) was WP 2.9.1

    Now it’s WP 3.0.1

    I’m on “standard” linux server with Apache PHP5x and MySQL5x.

    I’ve to use the plugin version 3.2.3 because with the last 3.2.4 I’m still getting the Fatal Error.

    About disabling the other plugins I’ve not tried yet.

    Disabling other plugins is the first step when you have an issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Google XML Sitempas] Fatal Error at line 910 of sitemap-ui.php’ is closed to new replies.