WordPress.org

Forums

[Plugin: Google XML Sitemaps] Your sitemap is being refreshed at the moment. Solution (19 posts)

  1. ljdiaz
    Member
    Posted 6 years ago #

    "Your sitemap is being refreshed at the moment. Depending on your blog size this might take some time! is not disappearing anymore." I did not do a thing, all I did was to pmake a post as usual, I know that this is working until yesterday, and then today, that message "Your sitemap is being refreshed at the moment. Depending on your blog size this might take some time!" is not disappearing anymore, the worst thing is that I even followed the solution on the last person who have had this problem, by unchecking the "build sitemap in background process..." but the problem is still there.

    Now my sitemap submission is not automated anymore, I have to do it manually from time to time.

    Any help from this?

    and another thing, I found out about this problem just today since I was about to donate for this plugin but as I was about to donate I noticed this so I am still observing it. If this wont be solved I think I would somehow temporarily halt my donation for this plugin.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. ljdiaz
    Member
    Posted 6 years ago #

    I did not know what happened but its ok now, my site is now available http://www.ljdiaz.com

  3. ljdiaz
    Member
    Posted 6 years ago #

    I have an update on this problem on how I solved it.

    Go to your dashboard > plugins > deactivate the google sitemap generator.
    then
    Got to your filemanager or login to your FTP Account and delete the old sitemap.xml and sitemap.xl.gz
    then
    Upload a new set of blank sitemap.xml and sitemap.xml.gz (read the readme included on this plugin on how to create those two files)
    then
    Go to your Dashboard > plugins > activate the google sitemap generator
    then Go to settings then click XML Sitemap then click the rebuild the sitemap manually
    then
    wait for it to load and whalla! the problem is gone away!

    for additional info or if you need more help visit my site at http://www.ljdiaz.com

  4. TheVirtualPreacher
    Member
    Posted 6 years ago #

    Hi,

    I had the same problem, and this is how I solved it.

    http://howtogeeksl.com/archives/326

    Please be kind enough to leave a comment if you find this useful.

  5. Arne Brachhold
    Member
    Posted 6 years ago #

    Looks like the Wp-Cron-Job which is set by the plugin is not executed or never completed. This could be an issue with the server configuration or maybe the script runs out of memory. Dos the debug mode of the build process run through successfully?

    @TheVirtualPreacher: I would like to have a look at your solution, unfortunately I can't access your site at the moment...

  6. Lovedoodle
    Member
    Posted 6 years ago #

    I'm still having this problem. That message is always showing (even after I've tried ljdiaz's solution twice) and it didn't work for me. New content on my blog is added everyday and I've found that the sitemap only updates when i click the 'rebuild sitemap manually' button, never on its own. If it is a Wp-Cron-Job problem what should I be looking for in the 'debug function'?

    FYI I'm kind of a noob at this.

  7. Lovedoodle
    Member
    Posted 6 years ago #

    Also, it was working on it's own at one point when the plugin was first installed, but it just stopped all of a sudden.

  8. Arne Brachhold
    Member
    Posted 6 years ago #

    Could you please try this version and post there if it helped?

    http://wordpress.org/support/topic/223608

  9. hypescience
    Member
    Posted 6 years ago #

    Hi, Arnee,

    I have the same issue. The version you suggested also doesnt work.

    Thank you

  10. Natrepub
    Member
    Posted 6 years ago #

    I am having the same problem. I downloaded the new version that Arnee recommended. WP 2.7.

    I have an update on this problem on how I solved it.

    Go to your dashboard > plugins > deactivate the google sitemap generator.
    then
    Got to your filemanager or login to your FTP Account and delete the old sitemap.xml and sitemap.xl.gz
    then
    Upload a new set of blank sitemap.xml and sitemap.xml.gz (read the readme included on this plugin on how to create those two files)
    then
    Go to your Dashboard > plugins > activate the google sitemap generator
    then Go to settings then click XML Sitemap then click the rebuild the sitemap manually
    then
    wait for it to load and whalla! the problem is gone away

    I tried this and it did not work either.

    Any suggestions or help?

  11. antonm80
    Member
    Posted 6 years ago #

    I have the same problem and I cannot make it work with the above mentioned. After rebuilding the sitemap "by hand" it still says it's having problems notifying Google, Ask.com and MSN about the new sitemap. Seems like something is going on with memory usage - says it took 17.25 Mb to build the sitemap. At the same time the file looks ok.

    Anybody can help me with that?

  12. Natrepub
    Member
    Posted 6 years ago #

    Anyone? Please!

  13. Milos Spasic
    Member
    Posted 6 years ago #

    I have upgraded WordPress 2 days ago to 2.7.1 and XML Sitemap Generator to 3.1.2. Before I made that upgrade, everything worked just fine, and now XML Sitemap Generator is displaying this message: "Your sitemap is being refreshed at the moment. Depending on your blog size this might take some time!"

    When i write a new post, site map isn't updating automatically, I must rebuild site map manually to include new posts. After manual rebuild new post are included in sitemap, but there still stands the message "Your sitemap is being refreshed...".

    I have tried all above recommended fixes, and nothing helps.
    Does anybody knows solution for this serious issue?

  14. Milos Spasic
    Member
    Posted 6 years ago #

    Today when I published post on my blog, XML Sitemap Generator warning message was disappeared, and the post was automatically added to Sitemap. Plugin is working normally now.

    The only thing I have changed in the meantime on my blog, is updating All in One SEO plugin to newest version 1.4.7.3 . It seams that there was a some kind of conflict between these two plugins, but that issue is fixed in this newest version of All in One SEO.

  15. postalservice14
    Member
    Posted 6 years ago #

    I don't think the main issue is a conflict between All in One SEO and Google XML Sitemaps because I have this problem and do not have All in One SEO installed.

    Any other suggestions?

  16. Milos Spasic
    Member
    Posted 6 years ago #

    I didn't say that that was the main issue, that was happened on my blog, and I wrote it down in hope that it will help someone.

    Try to disable all other plugins, except XML Sitemap Generator. Maybe it has conflict with some other plugin on your blog. If it starts working normally when you disable plugins, enable them one by one. When it stops working, you will find te plugin that is causing problems.

  17. ballinascreen
    Member
    Posted 5 years ago #

    I've experienced this issue several times - and the culprit tends to be a zombie entry in the WordPress' internal cron scheduler table. You'll need a plugin such as the excellent GD Press Tools to look at the contents of the cron scheduler.

    Hopefully you'll see an entry in there named 'sm_build_cron'. Simply 'unschedule' this entry and sanity should (hopefully) be restored.

    Worked for me anyway.

    Shane

  18. Arne Brachhold
    Member
    Posted 5 years ago #

    The next version will clear any old cron entries when you manually rebuild the sitemap or change configuration settings.

    At the moment I have no idea why sometimes the cron job is left in the list, since it is cleared before starting the sitemap process. Therefore it should be removed even if the build process breaks or runs out of memory for example...

  19. Kaktus
    Member
    Posted 5 years ago #

    I get these warnings in the debugging, I don't know if it has anything to do with it

    Errors, Warnings, Notices

    Notice: Undefined offset: 1 in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2435

    Notice: Undefined offset: 2 in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2436

    Notice: Undefined offset: 1 in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2436

    Notice: Undefined offset: 2 in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2437

    Notice: Undefined offset: 1 in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2437

    Warning: mktime() expects parameter 1 to be long, string given in /usr/home/myusername/domains/mydomain.com/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 2438

Topic Closed

This topic has been closed to new replies.

About this Topic