Support » Plugin: Google XML Sitemaps » [Plugin: Google XML Sitemaps] wordpress xml sitemap posting wrong links for posts

Viewing 9 replies - 1 through 9 (of 9 total)
  • %27 in URL encoding is the “” symbol. And the “\” is to escape a charcter. So its doing its job correctly which is to convert the URL to..well…a URL. which would require URL encoding. Much like when an ampersand “&” is needed it uses %26.

    To take care of all exceptions like url encoding, long urls, large number of urls etc. use Sitemap Generator tool and improve your search engine visibility

    Thank you. When I click on the links in my sitemap for posts, it says “error, page not found”. Are you saying that is correct, and how it is suppose to work?

    Not correct for a sitemap but correct for processing a URL.
    Since you are using %27 in your permalinks. This is causing similar problems elsewehere in your site Look at the bottom of the Post page at:at
    This entry was posted in Free Money for college, Free, Sales, Save. Bookmark the permalink.

    Notice WP has done the same thing here. Converted %27 to the character. This was done by WP and not by the sitemap plugin but the same theory applies. Do not use URL encoding (starting with %) in the URL/permalinks.

    How do I change this, and what should I change it to?

    You need to change your permalinks. Hav no idea what you have but it just can’t use %number as part of the URL.

    Why is everything in wordpress so difficult and why does every single topic I look at that may be able to help just have a load of bollocks written by someone spouting god knows what, romacox asked a very simple question to which as far as i can see no solution has been provided, just people trying to sound as pro as possible,

    people post questions to try to get resolutions, not to listen to you spout some crap you read somewhere and try to sound like a pro.

    I spend more time reading all this bullshit written by so called people who know what theyre doing than I DO BUILDING OR MAITAINING MY SITES on my own. If you cant answer in simple terms then fuck off! Were not impressed pase route % root % tking care of exceptions .

    If I didny have the same problems i’D FIND IT AMUSING but I dont its a pain in the arse.

    uninstalled sitemap plugin deleted sitemap files from root, re uploaded sitemap and sitemap zip blank to root, changed to chmoz 777 then re installed plugin!!!!! now my sitemap giving all kninds of crap 404links, how can this be when all files concerning original been deleted.

    Any genuine real world help would be appreciated all dicks spouting there bullshit please dont respond

    J

    Can someone tell me how to delete above post? all said in heat of moment & no excuse for foul language so apologies to anyone offended.

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Google XML Sitemaps] wordpress xml sitemap posting wrong links for posts’ is closed to new replies.