Support » Plugins » [Plugin: Google XML Sitemaps] Throws me back to login-screen

  • Just installed the plugin. If I try to build the first sitemap, or update any options, I get back to the login-screen and can’t even login anymore.

    I’d say it’s not working for me 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • It’s not working at the moment. I’m searching for a solution or update. Since.

    I have the same issue. I’m still logged in, but if I try to update the settings, I get the login screen and can’t “login” envn though I am logged in. strange.

    I have multiple domains. All running wordpress as blog/content management. On the redirected domains (via htaccess) there are a couple of plugins (wp recaptcha and xml sitemap generator) I am using where I kinda end up in a loop when trying to save the settings. If I select certain setting options, I am taken back to the login page of wordpress. However, the login page does not allow me to login to save the settings. I am however logged in. If I just shorten the url to the admin dashboard or any other admin area, no problem. Just won’t let me pass the login page when trying to save options on these 2 plugins. I have the plugins successfully working on my main domain, no problem with this issue. Only on the ones getting a htaccess redirect. I’m guessing it could be a problem with the htaccess file (who knows) or permissions (doubt it… but who knows). Anyway, if anyone has seen this behaviour and has a solution or even a good guess, I sure would appreciate it.


    I experienced the same problem and I’ve just managed to get around it.

    I was trying to use plugin this on my primary domain (on an account with multiple addon domains). In order to keep my public_html folder organized, I had been using an htaccess redirect to move my primary domain files into a subfolder (alongside the existing addon domains). This seems to have been causing the problem. When I undid my htaccess redirect, and moved my files back to their original location in the root of the public_html folder, the problem went away.

    Here’s a link to the original redirect instructions (from my host) that I was using:

    My guess is that there is a bug somewhere deep in the plugin that doesn’t allow it to function properly when used in conjunction with an htaccess redirect.

    I hope you find this helpful.


    This turns out to be a bug in the Plugin. Here’s how I fixed it:

    On line 360 of sitemap-ui.php remove the action=”…” section from the <form> tag. It’s unneeded since the page will automatically submit to the same URL and the getBackLink() code is clearly giving it the wrong URL. Once I did that it worked fine, even hosted under a different path and redirected with .htaccess rules. This is the only plugin I have that was suffering from this.

    It will now just read:

    <form method=”post”>



    Got the same problem with WordPress 2.6.5 and some .htaccess redirection like Trevor had. The problem is in sitemap-core.php in the function GetBackLink(). This function uses $_SERVER['PHP_SELF'] which is not correct in my and Trevors setup (it includes the sub-directory which we hide with redirection).

    Fixed it differently:
    Changed line 2433 of sitemap-core.php from:
    return $_SERVER['PHP_SELF'] . "?page=" . $page;
    return admin_url(basename($_SERVER['PHP_SELF'])) . "?page=" . $page;

    I’m not quite sure if this is valid for all the times the GetBackLink function is called, but it works for updating the settings and manually updating the sitemap.

    Thanks, the next version will use the admin_url function if possible (WP 2.6+)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Google XML Sitemaps] Throws me back to login-screen’ is closed to new replies.