[Plugin: Google XML Sitemaps] Sometimes it works, sometimes it doesn't (6 posts)

  1. babrees
    Posted 6 years ago #

    After installing this plugin it built the sitemap ok. After that sometimes it will rebuild and sometimes it won't. When it doesn't it gives the following message:

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 14.75MB, the limit of your server is 100M.
    # The last known execution time of the script was 1.03 seconds, the limit of your server is 120 seconds.
    # The script stopped around post number 11 (+/- 100)

    As you can see, it can't be the memory or time limit, it's a new site so does not exactly have much content at the moment, plus if it was due to the memory or time then why does it work sometimes?

    However, I did try increasing memory and time, but it didn't make any difference.

    When I click rebuild manually more often than not after a short time I end up at a blank page and have to return to the admin area, where I see the above error message.

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Try deactivate all of your plugins - except Google XML Sitemaps - and see if this resolves the problem. If it does, re-activate the plugins one by one – Google XML Sitemaps after each re-activation until you (hopefully) find the problematic plugin.

  3. babrees
    Posted 6 years ago #

    Thanks esmi - I tried that but it still didn't work with no plugins. Have installed it on other sites and it is the same on all of them.

    Yesterday I simply couldn't get it to work on a site. This morning I try to build it again and it worked :/

  4. esmi
    Forum Moderator
    Posted 6 years ago #

    If these sites are on shared servers, it could be that you're hitting problems when the server load is high.

  5. babrees
    Posted 6 years ago #

    Nope :(

    I got it to work earlier with no errors, but then after updating the site the auto build failed.

    I just tried a manual build again, server load was low but it still failed. After whirring for a few seconds I just get a blank page,

  6. babrees
    Posted 6 years ago #

    Had more failures and error messages since my last post.

    Just tried again, server load was roughly what it was when I tried last time and it failed (about 3.5). This time it worked!

    This is driving me mad.

Topic Closed

This topic has been closed to new replies.

About this Topic