WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Google XML Sitemaps] Small sitemap - last run didn't finish error (5 posts)

  1. bobinoz
    Member
    Posted 5 years ago #

    My blog only has around 180 pages yet I am having problems with my site map failing to complete. I have had the following error message:

    The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.
    * If you changed something on your server or blog, you should rebuild the sitemap manually.
    * If you encounter any problems with the build process you can use the debug function to get more information.

    When the build process does work it tells me....

    "The building process took about 10.43 seconds to complete and used 18.25 MB of memory."

    Well, I have set my limit to 32mb and time to unlimited, so why does it fail? 18 MB seems a lot of memory to use for such a small site anyway, why so much?

    After the last error Google only has 42 pages listed and a big red cross next to my status. Since this problem started about six days ago, my latest posts are not being indexed and I am losing my traffic fast.

    Any help would be appreciated.

    Thanks

    bob

  2. bobinoz
    Member
    Posted 5 years ago #

    A quick update. I asked my host if they could find any reason their end why the process was being stopped, and they couldn't. But they did say I could raise the limit to 64 MB as their server was okay with that.

    So I did and it worked at first but now I am getting the same error ....

    The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.

    ....even though it is only a small sitemap. Google is now listing only 33 pages.

    Can anyone help with this? I really would appreciate some advice.

  3. Rhand
    Member
    Posted 5 years ago #

    have you solved the problem yet? I have the same issue again. Once I solved it by checking MySQL standard mode, but that does not seem to help now..

  4. bobinoz
    Member
    Posted 5 years ago #

    No, sorry Rhand, never did find a solution. But I have found that building the sitemap manually always works, it just hardly ever works on auto. We are not alone, same problem is here.

    So these days I write my post, publish it and then go straight to the sitemap and manually build it. A complete pain and no use for scheduled posts.

    But for some reason, nobody has any answers.

    I'm using Thesis 1.6, WP 2.85 and xml sitemaps 3.17

  5. bobinoz
    Member
    Posted 5 years ago #

    I have posted a possible solution here, over at the other thread which is about almost the same thing.

    You might want to give it a try to see if it works for you before we can decide if it is a real solution.

Topic Closed

This topic has been closed to new replies.

About this Topic