WordPress.org

Support

Support » Plugins and Hacks » Google XML Sitemaps » [Resolved] [Plugin: Google XML Sitemaps] Sitemap Working Fine but failing on Google! (Enough info to help me)

[Resolved] [Plugin: Google XML Sitemaps] Sitemap Working Fine but failing on Google! (Enough info to help me)

  • Sitemap Working Fine but failing on google!

    Using
    Wordpress 3.0.1
    PHP 5.3x (Already changed split() to explode() ) The plug.in wasnt working before that…
    xml and xml.gz generates fine but google has a problem to read

    Google Error

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    Robots.txt

    User-agent: *
    Allow: /
    
    Sitemap: http://www.wrzblog.net/sitemap.xml.gz

    Links
    http://www.wrzblog.net/robots.txt
    http://www.wrzblog.net/sitemap.xml
    http://www.wrzblog.net/sitemap.xml.gz

    Everything was working fine until some days ago….

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Contributor Arne Brachhold

    @arnee

    Sometimes there is just a network problem. Can you try to resubmit your site manually in Google and see if the problem persists?

    I already did that several times :/
    Although yesterday I changed the virtual robot.txt that wordpress to agent allow…
    Hopefully today google will re-download my robots.txt and see if the change from non to agent allow make the sitemap work again.

    Google already re-downloaded my robots.txt but still sitemap its not working :/

    When I try opening your gzipped sitemap I get control characters instead of XML text. That is your problem…

    The same problem here:
    http://www.saltea.net/sitemap.xml
    Google encountered an error while trying to access the sitemap
    Please tell me how to fix this.

    Same with me.

    In Google Webmaster Tools, I have a red X under status for my sitemaps:

    http:/www.systhermique.com/sitemap.xml
    http:/www.systhermique.com/sitemap.xml.gz

    @popsie
    It looks like you did not use the WordPress plugin to create the sitemap. Try using it.,

    @jfl1
    Can not help with the webmaster tools. Your sitemaps look fine.

    Thanks webjunk,

    there might be temporarily something wrong with Webmaster Tools.

    Is there any point at all in registering my sitemap there as long as the plugin is updating it regularly? It’s a question I’ve been asking myself.

    webjunk anyway to fix my problem? 😐
    Thanx BTW

    @xfernanx
    Try manually recreating the sitemap. Then take a look yourself to see if it opens & reads properly.

    By recreating you mean rebuild the sitemap manually via the plug-in all or the sitemap myself?
    And how can I check if its ok?
    Sorry but im a noob when it comes to sitemaps lol

    Create through the plugin in wp-admin

    Check it by viewing like the bots do:
    http://www.wrzblog.net/sitemap.xml
    http://www.wrzblog.net/sitemap.xml.gz

    It opens properly for me 😐

    If you still have the plugin enabled then maybe it recreated the sitemap since your initial posting and fixed the issue. Resubmit to Google.

    I mean I already re-created the sitemap several times and resubmitted several times but it seems theres no solution! 🙁

    What about t e thing you said about the control characters anyway to check if they stil there or how to remove them? 😐

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] [Plugin: Google XML Sitemaps] Sitemap Working Fine but failing on Google! (Enough info to help me)’ is closed to new replies.
Skip to toolbar