WordPress.org

Support

Support » Plugins and Hacks » Google XML Sitemaps » [Plugin: Google XML Sitemaps] Not working when accessing the dashboard via an SSL URL

[Plugin: Google XML Sitemaps] Not working when accessing the dashboard via an SSL URL

  • I’m using managing a WP Network using a secure URL (SSL) and the plugin generates SSL URLs for the sitemap instead of the normal ones.

Viewing 2 replies - 1 through 2 (of 2 total)
  • In Summary there are two problems with the plugin when using FORCE_SSL_ADMIN.
    1)Automatic detection of the sitemap file doesn’t work in the backend. https is added to the filename and the URL starts with https. The generated URL will be different when somebody is visiting the site.
    2)Links in the sitemap file that we can access to from the backend are all https links.

    Plugin Contributor Arne Brachhold

    @arnee

    Hi Olivier,

    the plugin doesn’t generate any links by itself but uses the WP API with functions like get_bloginfo(‘url’) to get the Blog URL and get_permalink() to get the post URLs. I could add a workaround by changing the results of the API calls to http, but I really think this issue needs to be fixed somewhere else.

    I guess when you open the edit post screen and click the Preview button, it also opens the post on your main site with https, right?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Google XML Sitemaps] Not working when accessing the dashboard via an SSL URL’ is closed to new replies.
Skip to toolbar