WordPress.org

Forums

[Plugin: Google XML Sitemaps] Images are not indexed in google images (5 posts)

  1. Eviternity
    Member
    Posted 5 years ago #

    I'm running WordPress 2.9.2 at the moment and use Google XML Sitemaps 3.2.2 now for quite some time.

    My problem is that the images I upload and attach to the blogs are not indexed by Google.

    I use the standard settings of XML Sitemaps and have no robots.txt in the root. The images are shown on the blog by Lightbox 2.9.2, but I guess that shouldn't matter anything.
    All the media are in the folder: /wp-content/uploads/
    Which are automatically sort into: /wp-content/uploads/year/month/

    Does someone has the same problem or am I alone and does someone know how to solve this problem?

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  2. Eviternity
    Member
    Posted 5 years ago #

    Serious, does no one has this problem too?
    Am I really alone on this part. How did you guys solve it?

  3. jasondjones
    Member
    Posted 5 years ago #

    I just discovered I also have this problem and also run the google sitemap generator.

  4. vici
    Member
    Posted 5 years ago #

    I have that problem too. Google images is an important traffic source for my website so why don't you examine this issue?

  5. Lee Willis
    Member
    Posted 4 years ago #

    There's really nothing to examine here - it's up to Google what they choose to index. If the images are on your site, and you're not blocking them via robots.txt then you're most of the way there. In my experience sites have to rank pretty well already (Or be for fairly niche terms) before the image search picks them up.

    However - if you use post thumbnails, then this might help:
    http://www.leewillis.co.uk/adding-post-thumbnails-to-sitemap/

    However, it's still up to Google what they choose to index ...

Topic Closed

This topic has been closed to new replies.

About this Topic