Support » Plugins » [Plugin: Google XML Sitemaps] I cant generate sitemap

  • I cant create my sitemap :S

    This is the error:

    # There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    # There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more
    # The building process took about 0 seconds to complete and used 20 MB of memory.

    My files and permisions:
    http://img194.imageshack.us/img194/733/capturai.jpg

    Can you help me? Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem

    I use wordpress 2.8.1
    I have updated to 2.8.2 and the error its same.

    the sitemap.xml and sitemap.xml.gz files need to be in the wordpress root directory, in which directory are they there on your pic?

    Yeah, html_public. With the archive wp-config.php

    Please, help me! 🙁

    Also having the same problem. Files are in the root directory & permissions set to 777.

    This is a bug? Please fix or help me 🙁

    Kwegner, the permissions should be set to 666, not 777. Otherwise the plugin won’t be able to overwrite the file.

    I used the debug mode and I obtain this:

    Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/My-user:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/My-user/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 1627

    trullinger: 777 is read/write/execute for owner/group/everyone, whereas 666 is read/write for owner/group/everyone, therefore 777 will always overwrite under normal circumstances.

    GrYf: Seems there are some path issues. Might need to add your wp path to the PATH too. Alternatively you can check with your hoster if you can disable the open_basedir in php.ini file, or use ini_set to disable it.

    Hi i encounter the same issue as well

    but i not sure i upload it to the correct location ?
    please refer to this picture :http://i896.photobucket.com/albums/ac163/anthonyportal/root.jpg

    I think it should be root “/www”

    any help will appreciate

    Thank you,
    best regards
    Anthony

    My two files site in the domain root directory — where my index.php and .htaccess files live — WordPress files are separately in their own directory (which I have in my settings section of the Dashboard).

    Can you go to … http://www.yourdomainname.com/sitemap.xml and see there is a file, even though it is empty? Same for the zipped file?

    PS: I used these instructions to help me install this plugin today:

    Google Sitemaps FAQ (Sitemap Issues And Errors)

    I had this error, and spent a while trying to figure it out..
    I figured out my problem.
    The issue was that I had wordpress installed to wordpress.mysite.com
    but I had it setup so that mysite.com would display it.

    So to fix the issue I went to the configuration options
    In location of your sitemap file I chose custom location.
    Put in the absolute path (/home/websites/www.mysite.com/public_html/sitemap.xml)
    I generated a blank sitemap.xml and sitemap.xml.gz files and set the permissions to 777 on those 2 files.
    Clicked on rebuild sitemap and it worked fine.

    This is a really stupid problem to have, it seems that most people that are having this problem is because they have sub-directories with a number of wordpress blogs.
    ‘Interested Mind’ I think you have the right idea as the “automatic Detection’ pretty much sucks and doesn’t look to where the site map is or should be so ppl will need to create a custom location to where the sitemap really should be located.

    http://bluefoxmarketing.org/images/site_map_error.png

    The problem is finding and knowing the exact directory to point to or at least knowing what custom location to point to for the sitemap?

    ^ Indeed

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Google XML Sitemaps] I cant generate sitemap’ is closed to new replies.