WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Google XML Sitemaps] HTTPS links are generated by mistake when logged in as Admin using SSL

[Plugin: Google XML Sitemaps] HTTPS links are generated by mistake when logged in as Admin using SSL

  • Meliovation
    Member

    @meliovation

    The sitemap output is generating links using https:// instead of http://

    I believe this happens because I am logged in using HTTPS when managing the blog and writing post content. This also causes the sitmap.xml file to be hosted on an HTTPS path only.

    However when I click the link on the plug-in settings page to generate the sitemap manually, it generates the links correctly as HTTP and puts the sitmap file on http:// as well.

    This sounds like an important issue to resolve since it is recommended that WordPress admins use SSL when managing the site. Can this be fixed or is this another problem that you are aware of?

    http://wordpress.org/extend/plugins/google-sitemap-generator/

Viewing 2 replies - 1 through 2 (of 2 total)
  • jcottone
    Member

    @jcottone

    I had the same issue. In sitemap-core.php, line 361 I replace this:

    return str_replace ( array ( '&', '"', "'", '<', '>'), array ( '&' , '"', ''' , '<' , '>'), $string);

    With this:

    return str_replace ( array ( '&', '"', "'", '<', '>' , 'https'), array ( '&' , '"', ''' , '<' , '>' , 'http'), $string);

    biswajeet
    Participant

    @biswajeet

    @jcottone thanks for the tips! But there required a permanent fix in the upcoming release regarding this particular thing.

    btw, if suppose a stable site with good ranks in google suddenly change all the links in the sitemap to https then how google will treat these redundant links. Will such situation lead to any penalty or loss of page rank?

    If this can lead to loss of page rank, then its a matter of high concern and the author is advised to resolved this bug asap in the next release.

    Can anyone share any experiences regarding the above mentioned situation…

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Google XML Sitemaps] HTTPS links are generated by mistake when logged in as Admin using SSL’ is closed to new replies.