WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Google XML Sitemaps] How To Exclude Certain Pages?

[Plugin: Google XML Sitemaps] How To Exclude Certain Pages?

Viewing 11 replies - 1 through 11 (of 11 total)
  • doctorlecter
    Member

    @doctorlecter

    Pages ARE posts and have a post id. See the link when hovering a page in the backend. There you see soemthing like

    http://www.domain.tld/wp-admin/post.php?post=3&action=edit

    post=3 is your thing!

    Exclude post 3 and the page is gone.

    so i tried that…site is aaaphotobooth.com

    trying to get “newsletter subscription success” to disappear from site map.

    Went to exclude posts, entered that post’s ID which is 250

    But that link is still there on my sitemap…any ideas?

    thx 🙂

    doctorlecter
    Member

    @doctorlecter

    Did you generate the sitemap new “from hand”?

    Normally it’s only generated when you change someting. (Add or delete a page)

    So if you change the settings you have to generate a new sitemap.

    ohh..good one..I’ll go add a page now and see if that shows the change 🙂 I’m a bit new at this 🙂

    Well, it immediately added the new “test page” link but did not exclude the other lol..hmmm…maybe because I have “include static pages” checked?

    doctorlecter
    Member

    @doctorlecter

    You don’t need to add a page for that.

    Go to
    – Settings
    – XML-Sitemap

    In the upper part of the plugin is the possibility to generate a new sitemap. (Don’t know how this link is named in english because i use it in german.)

    doctorlecter
    Member

    @doctorlecter

    I tried it in another of my pages. Excluded page “4” – the imprint.
    Saved the new config.
    Generated a new sitemap…

    Imprint is gone – no problem…

    Yes, did a manual rebuild and the link is till there, plus the link to the new page “test Page”

    hmmm, do I add more than just the ID numbers, separated by commas? For my exclusions I typed

    250,284

    for the two pages I’m trying to exclude

    maybe because its a child theme?

    Had this problem as well. Actually, the site map is probably updating and taking the page out, but you have to reload the page in your browser or it doesn’t show the change. It took physically deleting the page and it STILL was there for me to realize that it must not have been refreshing in the browser.

    So after you do a manual refresh, and you click on the link to the site map, force the page to reload in your browser once it’s loaded.

    🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Google XML Sitemaps] How To Exclude Certain Pages?’ is closed to new replies.