Support » Plugin: Google XML Sitemaps » [Plugin: Google XML Sitemaps] Early testers wanted

  • Hi,

    I’m currently working on a new version of the plugin which will have some major changes. To test this new features, I need your help. You can grab the new version here:

    Please note that it is in a very early stage and not suitable for production sites. Please also note that you have to delete your sitemap.xml and sitemap.xml.gz after installation since they are not used anymore (but break the new plugin).

    What has changed:
    Dynamic sitemap generation
    There are no static files anymore. This will solve 99% of the problems users are having. All content is generated dynamically.

    Sitemap Index File
    To reduce the amount of needed CPU and memory, the sitemap is split into sub-sitemaps. The main sitemap file is now only a index file which links to them. With that change you can have an unlimited number of URLs as long as they are spread over multiple months.

    WordPress MU support
    Without having static files, MU and multi-site support is no problem anymore.

    New developer API
    With the new API, developers can build plugins which can create sub-sitemaps to support an unlimited number of items.


    • Install the plugin normally
    • Delete your existing sitemap.xml and sitemap.xml.gz
    • Browse to if using rewrite permalinks, or index.php?xml_sitemap=index if not.

    At the moment, WordPress 3.0 and PHP 5.2 is the only tested configuration. Please let me know if you have problems with other setups.

Viewing 15 replies - 46 through 60 (of 199 total)
  • OK, it appears I “fixed” this by just forcing things along with a non-permalink visit to the sitemap. Once that was done, the permalink worked. *shrug*

    Spoke too soon. Well, this is a different error.

    Our site has a LOT of tags. When trying to use the sitemap-tags.xml file, it bombs:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 262144 bytes) in /home/www/ on line 2269

    This didn’t happen with the older plugin. Tried increasing memory in the options for the plugin, but did no good. For now, to get it working at least somewhat, I turned off tag sitemaps for this one site. That is working so far, but it’s not mapping those pages anymore.


    I just check your site and saw this too. Can you give me a number about how many tags you have? I have several testing blogs with dummy data and was trying them out before. One of them has around 1000 tags and needs 21MB. 18MB is already the WordPress base, so generating the tag page needs only 3MB.

    Also the way the tags are retrieved didn’t really change… Do you have any other plugins running which could interfere with the tags?

    It would be good to know what causes the memory usage. Is it the building of the permalinks or the tag query? For that you can open the sitemap-builder.php and search for the “BuildTags” function. Comment out the “$gsg->AddUrl…” line and see how much memory it uses now. Of course the page will be empty, but the memory usage should be visible in the source code. Thanks!

    We’re talking over 20k tags. I got around the issue by increasing the maximum script size in php.ini, so I’m all set.

    One other thing I noticed: it appears archive sitemaps are broken. When I tried that, the urls it gave for the archive sitemaps did not end with ‘sitemap.xml’. I turned off archives for now.

    Here’s the link, so you can see what I mean:

    Same for other sites:

    20k? Ok thats a lot… The problem is that WordPres tries to cache everything, the query result, the objects and so on. So there will be probably a few 20k arrays in the memory somewhere.

    For me the archives look fine? They should point to the WP archives like

    Ah, I see. My problem is I don’t handle archives with my theme properly. So, turning them off is just fine. 🙂

    @arnee – The custom post type functionality was so close! Those minor fixes that I did (and I posted the code here in the thread) fixed it completely on my site. If you need help getting that functionality working, just let me know. I’m pretty busy, but I’m sure I can find time to get you a patch.

    As of now though, I’m sticking with my modified version of your alpha-4 release, because 95% of the content on my new site are custom post types.

    Really looking forward to those custom posts 😀

    me too:)

    aaroncamplbell: could you maybe share your modified version?



    I’ve been testing 4.0a5 on a wordpress install with over >180k posts and I’m impressed by the stability and speed already! The only time it breaks is on a few months with >10k posts. I get a “XML Parsing Error: no element found” error on those months. Is there a way I can help with some debug info?

    @vlp: my changes were posted previously in this thread.

    I have downloaded the latest 4.0a5 and could not get it to generate a Site map. I edited two posts and updated no sitemap.

    after plugin was activated i realized I tried the 4.01a version a while ago and that did not work either then I switched to simple sitemap and that worked but I rather use yours.
    WP3.01 multisite.
    url to site

    Aaron, thank you very much again for your changes. I will integrate them later for sure!

    n2rga, could you give me more details about what exactly didn’t work? What happened when you tried to access the sitemap?

    the generation of a sitemap did not work it when to a you page could not be found page.
    I’m going to try again now as I write this.
    deleted simple sitemap plug-in and install yours alpha5 and activated still had my settings in the database. went over them and Hit the link to the sitemap on the settings page and got this
    Sorry, we can't find the content you're looking for at this URL. Please try selecting a menu item from above or to the side of this message to get where you'd like to go.

    I will leave it installed so we can fix this

Viewing 15 replies - 46 through 60 (of 199 total)
  • The topic ‘[Plugin: Google XML Sitemaps] Early testers wanted’ is closed to new replies.