WordPress.org

Forums

[Plugin: Google XML Sitemaps] Blank Settings page (25 posts)

  1. jeremycherfas
    Member
    Posted 5 years ago #

    Using Google XML sitemaps 3.1.5 and WP 2.8.4 I get a completely blank page when I click on the settings page. The same was happening with 3.1.4 and I just upgraded.

    Is there any easy solution, or should I delete and reinstall?

    Thanks

  2. geodv
    Member
    Posted 5 years ago #

    My site either loads half way, or the header only with errors after i upgraded from 3.1.3 to 3.1.5. I had made a back up of my database before i upgraded, however, even with I uploaded my backup of my database the site was and is acting weird. Is there a solutiong to this? Please let me know. Thanks

  3. chipchick
    Member
    Posted 5 years ago #

    i"m having the same problem on 2 different blogs. One blog running 2.6 and one 2.8.1

    Has anyone figured this out?

  4. chipchick
    Member
    Posted 5 years ago #

    I've discovered that if i have WP-Super cache enabled, I am not able to access the Google Sitemap settings

  5. jackyfox
    Member
    Posted 5 years ago #

    chipchick, rights.
    Without WP Super Cache XML Sitemap wokrs fine

  6. pRoth1981
    Member
    Posted 5 years ago #

    I'm using Google XML Sitemaps 3.1.6 with WP 2.8.3 and also only get a blank page instead of the configuration page. i'm not using WP Super Cache...

    does anybody have a solution for that?!

  7. jackyfox
    Member
    Posted 5 years ago #

    Blank settings page spotted with wp-useronline active plugin.

    WP 2.8.4

  8. jackyfox
    Member
    Posted 5 years ago #

    Blank settings page spotted with smart-youtube active plugin.

    Still WP 2.8.4
    Guys, what's wrong with XML-sitemap plugin? I'm really disappointed.
    Афтар, давай починяй ужо...

  9. Arne Brachhold
    Member
    Posted 5 years ago #

    Hi,

    I tried several of your mentioned plugins and could not fond any problems. Do you have access to your web servers error logfile? Maybe we can find something there.

  10. ucc360
    Member
    Posted 5 years ago #

    Hey there, I have the same problem; an empty configuration page. Funny thing is, I have no other Plug-in running. I'm running WP 2.8.6.

    I examined the source code an found, that the output was interuppted as you can see:

    <div id="wpbody-content">
    <div id="screen-meta">
    	<div id="contextual-help-wrap" class="hidden">
    	<h5>Hilfe zu “XML-Sitemap Generator”</h5><div class="metabox-prefs"><a href="…">Plugin Homepage</a><br /><a href="…">Sitemap FAQ</a></div>
    <h5>Weitere Hilfe</h5><div class="metabox-prefs"><a href="…" target="_blank">Dokumentation</a> (<a href="…" target="_blank">en</a>)<br /><a href="…" target="_blank">WordPress Support-Foren</a> (<a href="…" target="_blank">en</a>)</div>
    
    	</div>

    I'm willing to help, but I don't know how to access the server logs (it might not be possible).

  11. Concerto
    Member
    Posted 5 years ago #

    Hi,
    i've got the same blank configuration page problem.
    I'm on a fresh WordPress 2.8.6 and i have no other plugin installed.

    Of course i've set the chmod on the 2 sitemaps files at the wordpress root folder.

    Is there a solution to that issue ?

    Thank you

  12. Concerto
    Member
    Posted 5 years ago #

    I've fixed my problem by forcing the PHP5 support (i'm on 1and1).

    I had that line in the .htaccess file :
    AddType x-mapp-php5 .php

    Hope it will help other users

    Thx

  13. Arne Brachhold
    Member
    Posted 5 years ago #

    Hi,

    Great, thats a good hint! Maybe its a PHP4 problem. I've tested only with PHP 4.4.9, so could somebody of you find out which PHP version is installed on your server?

  14. ucc360
    Member
    Posted 5 years ago #

    Hi Arnee, (great plug-in btw)

    I just checked via phpinfo() and I also have 4.4.9 – however after forcing php5 (Thanx Concerto!) it seems to be working.

    May be there is some buggy php4 function in use, I havn't lookes at the code.

    So a solution may be to force php5.

  15. jackyfox
    Member
    Posted 5 years ago #

    I'm using
    Apache 1.3.41 (Unix)
    PHP 5.2.8
    MySQL 5.0.85-community
    x64 Linux

  16. jackyfox
    Member
    Posted 5 years ago #

    On 2.8.6 works fine.
    Thanks

  17. ildido
    Member
    Posted 5 years ago #

    I've got the same problem.
    As far as I can tell I get a blank settings page only when at least one of these plugins is active:

    WP-CommentNavi
    WordPress Database Backup
    WP Super Cache

    (WP 2.9.1 - Apache/2.0.52 - PHP Version 4.3.9)

  18. Ray111
    Member
    Posted 5 years ago #

    Thanks ildido! I simply deactivated WordPress Database Backup and it appeared!

  19. vickiberry
    Member
    Posted 4 years ago #

    I have SQL 5 and WP 2.9.2 and get a blank settings page for the Google XML sitemap -

    I do not have the "AddType x-mapp-php5 .php" line in my .htaccess file as far as I know because I did not add it and I did upgrade my database from SQL 4 to 5 --- also I DO have WordPress Database Backup installed, and as ildido says that seems to be an interaction problem.

    Any ideas on whether I should just add the .htaccess line ? I am not a php person so would like some input before I go messing around with it!

    Thanks,
    Vicki

  20. mistercyril
    Member
    Posted 4 years ago #

    Up to date list of conflicting plug-ins :

    • WP Super Cache
    • wp-useronline
    • smart-youtube
    • WP-CommentNavi
    • WordPress Database Backup
    • Get recent comments

    Anything else?

  21. Fredto
    Member
    Posted 4 years ago #

    I can add those two to the list:
    WP-ContactForm
    Secure and Accessible PHP Contact Form

    Never got the to the settings page with those enabled.

  22. commercialscott
    Member
    Posted 4 years ago #

    You have to make sure your site url and xml url are in harmony. I suggest this before playing with plugins and other stuff:

    Go to settings>general
    check your site address url. Is it http://www.mysite.com or is it mysite.com?

    Go to settings>xml-sitemap
    Go to 'location of your sitemap file'. Make sure the detected url (or custom depending on what you are using) matches what was in your general settings with the addition of /sitemap.xml (or whatever you call yours).

    If you have http://www.mysite.com and your xml is mysite.com/sitemap.xml it won't work. Make sure they both either have or don't have www.

  23. slushpilejs
    Member
    Posted 4 years ago #

    commercialscott: the point of this entire thread is that we CAN'T GET TO settings>xml-sitemap.

    Having said that, I've upgraded to WP 3.0.1 and Google XML Sitemaps 3.2.4 and even if I had disabled all other plugins, I still got the blank settings screen.

    So just now I completely deleted it and re-installed it from scratch. It seems to be working...

  24. Arne Brachhold
    Member
    Posted 4 years ago #

    I'm not aware of any plugins which break the sitemap plugin. If you still have the blank screen problem, please contact me so I can have a look at your configuration.

  25. rot69
    Member
    Posted 4 years ago #

    Thank you concerto. Adding line:
    AddType x-mapp-php5 .php
    to the htaccess file fixed it in a second.
    (I'm as well using 1&1 hosting)

    Thank you Arnee for a great Plug-in. I hope this issue will be resolved ASAP.

    WP ver. 3.0.1
    Plugin Ver. 3.2.4
    Only All-in-one-SEO-Pack plugin installed and active.

Topic Closed

This topic has been closed to new replies.

About this Topic