Support » Plugin: XML Sitemaps » [Plugin: Google XML Sitemaps] Auto-build never works; Manual build always does

  • Hi,
    The automatic rebuild of my sitemap never appears to work. Every time I go into the plug-in page it shows as having had problems.

    Unfortunately I cannot say where is the problem. The plugin work under the limits (also memory also time) but cannot finish to complete the sitemap.

    However, the solution every time is to rebuild manually. I don’t change any other settings but merely click the rebuild manually link and it rebuilds the sitemap and reports it to Google, etc.

    I actived the background option long times ago.

    Why would this be?

    Thanks a lot

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m having exactly the same issue. Seems to have started when I updated WP SUpercache to 1.1. I’ve since reverted to version 1.0 of WP SC, but am still seeing this problem with scheduled posts. This is ONLY on automated builds, the manual rebuilds work just fine. It’s quite odd.

    Thread Starter Matrix


    I hope that someone would answer… 😉

    I’m having the same problem. No automatic builds but manual builds work fine with no changed settings.



    I am having the same problem, please support, can you help us out here??



    Manual rebuild doesn’t work. It indicates that a sitemap was updated. However, if you check a sitemap, it has outdated information. Please help us! We hope that you are well. Thank you

    I’m having the same problem. Manual builds work fine.

    Sounds like all of you are having problems due to your server not supporting loopback requests.

    Ok here are two files i’ve written for ya to help test if your server is functioning correctly.

    1. Change {SITE HOST NAME} in the code (two spots).
    2. Place them both on your server.
    3. Run LoopbackTest-Call.php from your browser.


    	$ch = curl_init();
    	echo "<b><u>Server: ".$_SERVER["SERVER_ADDR"]."</u></b><br/><br/>";
    	curl_setopt($ch, CURLOPT_URL, 'http://{SITE HOST NAME}/LoopbackTest-Reply.php');
    	curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    	$html = curl_exec($ch);
    	echo "This php file attempts to test Loopback Requests by calling: <b>http://{SITE HOST NAME}/LoopbackTest-Reply.php</b> which resides on the same server<ul><li>If the response fails the display shows \"<u><b>FAILED!</b></u>\" and means Loopback Requests are not working on this server.</li><li>If the response is successful the display shows \"<u><b>SUCCESS!! Loopback Requests Work!</b></u>\" and means Loopback Requests are working on this server.</li></ul>Response: ".(strlen($html)==0?"<b style='color:#FF0000'>FAILED!</b>":$html);


    	echo "<b style='color:#00FF00'>SUCCESS!! Loopback Requests Work!</b>";

    Let me know the results. If it says FAILED then i will let you know what you need to do.

    Result: Success!!

    Do you have anything in your error_log file?

    I will have a look at the author’s source code to see what’s going on.

    When you create and publish a post does this plugin successfully create your new updated sitemap with the new post? I am just curious if this problem is only occurring for scheduled posts.

    Also, are you using any page caching plugins? I know a plugin called Quick Cache has an issue with scheduled posts which i had to provide a patch fix for other users to use which then resolved why XML sitemap wasnt working (in their specific case).

    I have the problem that automatic updates aren’t working, but manual ones are. Updates via the GET request also appear to work OK.

    I got ‘Failed’ when I tried your loopback test. Do you know what I should do to fix the problem?


    +1 for the issue on Windows server 2003.

    Tried the test script and got a fail. It didn’t look like the server name variable was being populated. When I hard coded it, it gave a success result.

    It looks like support for this plugin does not exist. I have the same problem as above. Manual updates don’t work. I haven’t updated anything in the last few days as far as code or plugins. I changed several pages and one post and I added a page to be excluded. The sitemap does not update manually or automatically to reflect these changes. Tried it several times. Even deactivated the plugin and deleted it and uploaded again. No luck. This did work a couple of days ago but no longer does.

    Running the latest version of the plugin and WP 3.5

    I’m having the same problem.

    About a month ago I created the first sitemap of my site. Since then I uninstalled a plugin called store locator plus and all the store pages that came with it where also deleted. I have then uploaded a new directory theme and created new custom posts for each of the listings in my site. A few days ago I tried to run xml sitempas to create a new sitemap, I tried clicking on the link to create it manually, but the sitemap still shows all the old pages with storelocator….. in the url. I have in fact found some of these links in google and, of course if you click on the link you get a 404 message. Basically google thinks that most of my content is 404!!!!! It’s a disaster.
    How can I delete the old sitemap and build a new one?

    Hope someone can help.

    Many thanks in advance 🙂 sonia
    I apologise for the long message but I thought it was better to explain in details…..

    You don’t say whether the manual rebuild gave a success message, or not.

    If it thought it worked, it’s possible that store locator plus (I’ve not used it) has left some stuff behind and that the sitemap plugin is picking it up. If you look at the ‘Sitemap content’ section of the XML Sitemap settings page, you might see one or more custom post types relating to store locator; if so, uncheck them, click ‘Update settings’ and then rebuild.

    Otherwise, if the manual rebuild is showing a failure message, I’d suggest replacing the sitemap.xml file with a blank one, check the permissions and try again. That way, at least, you’re giving Google and others a hint the pages no longer exist.

    Got the Webmaster Tools “Googlebot can’t access your site” email – it seems to resolve itself after manual rebuild. However, I have just realised that I had WordPress SEO by Yoast activated with the XML sitemaps option ticked, so I wonder if this could have caused the conflict.

    Have just disabled Google XML Sitemaps so will feedback in the next few weeks if there are further problems. I am a fan of this plugin having used it for many years on other sites with no issues, so am hoping its because of a plugin incompatibility issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Google XML Sitemaps] Auto-build never works; Manual build always does’ is closed to new replies.