WordPress.org

Forums

[Plugin: Google XML Sitemaps] Additional and Excluded Pages not working in version 3.1.0.1 (7 posts)

  1. Jeff Starr
    Member
    Posted 6 years ago #

    Hi,

    I am running the Google XML Sitemap plugin with WordPress 2.5.1.

    Everything is great, except for a couple of issues with adding and excluding specific pages.

    First, the "Add New Page" function for the "Additional Pages" section is just not working at all. Nothing happens when you click the "Add New Page" link. I dug around in the source code and compared a couple of databases, and it looks like the option field to add new pages does not exist in this version.

    Second, the "Exclude the following posts or pages" function in the "Basic Options" section also not working. It *looks* like it works, but nothing is saved and the URL(s) just seem to disappear.

    Would *love* to get this working. The ability to include and exclude specific pages is a critical component of proper XML sitemaps.

    Thanks for your help!

  2. Ganka
    Member
    Posted 6 years ago #

    I have the same problem… the JavaScript link for adding additional pages to the Sitemap file doesn’t work at all.

  3. Jeff Starr
    Member
    Posted 6 years ago #

    Unfortunately, I think the problem goes deeper than just the JavaScript not working; I am fairly certain that the PHP/SQL required for such functionality is missing completely. I.e., even if the JavaScript links did work, any submitted data would not be saved into the database.

    Would love to hear a response for this issue.. :)

  4. Ganka
    Member
    Posted 6 years ago #

    Has the problem existed in the previous versions of the plug-in?

  5. Jeff Starr
    Member
    Posted 6 years ago #

    No, although I don't know which version first presents the error. I am currently using version 3.0.3 successfully on 2.3.3 installation of WordPress. It's the newer version(s) (e.g., version 3.1.0.1) of the Google XML Sitemap plugin that have the problem. Would be great to get some help with this..

  6. PozHonks
    Member
    Posted 6 years ago #

    For the Adding Pages function, it's a bug only with version 3.1.0.1 !

    Open the file sitemap-ui.php, on line 791, find:
    <script type="text/javascript" src="<?php echo $this->sg->GetPluginUrl(); ?>/img/sitemap.js"></script>
    and replace it with:
    <script type="text/javascript" src="<?php echo $this->sg->GetPluginUrl(); ?>img/sitemap.js"></script>

    Just remove the first slash in front of img/sitemap.js. It is a path bug.

  7. Arne Brachhold
    Member
    Posted 6 years ago #

    Thanks for the note PozHonks, this will be included in the next version!

Topic Closed

This topic has been closed to new replies.

About this Topic