Support » Plugin: Google XML Sitemaps » [Plugin: Google XML Sitemaps] 4.0beta8 404 Error

Viewing 15 replies - 1 through 15 (of 17 total)
  • Any tips? My site is running on nginx 0.8.54.

    What did you have to do to fix this? I am getting same problem.

    I haven’t found a fix yet. I’ve switched back to the old stable release version.

    I installed the Version 3.2.6.2 today and it looked as if it’s working, but when I tried submitting a sitemap to webmaster tools it said they could only reach Page 404 and the submission failed.

    I’m new to wordpress and websites – can anyone help and tell me what to do?

    carol

    karaloko

    (@karaloko)

    I’m having the same problem, can anyone help us?

    DirtyPete

    (@dirtypete)

    I’m getting this too. 404s on root domain.

    Plugin Contributor Arne Brachhold

    (@arnee)

    Hi,

    sorry, I havent been able to reproduce this error yet. I’ve tried many different server and PHP configurations, but it always works. Could somebody of you contact me via himself / arnebrachhold / de so we can debug this issue on your server? Thanks a lot!

    Best regards,

    Arne

    brohism

    (@brohism)

    Email sent.

    Plugin Contributor Arne Brachhold

    (@arnee)

    Hi,

    is somebody else still having this issue?

    No problems any more. Thanks. Working well on both sites: 🙂

    http://www.mysecondmillion.com
    http://addictionrehabnow.com

    Plugin Contributor Arne Brachhold

    (@arnee)

    Did you do anything to make it work?

    No, I thought it was your magic touch! At least, I don’t think I did – I fretted a bit, but otherwise, I wouldn’t know what to do anyway…..:)

    I found a fix for those still having this issue. Nginx needs to be told to pass requests for sitemap.xml to WordPress for handling, rather than try to serve a static file. Here’s what I added inside the Nginx server config:

    location ~* ^(/sitemap).*(\.xml)$ {
      rewrite ^ /index.php;
    }

    It’s working perfectly for me now.

    Sir,

    Please help me i am also facinng same problem , 404 error , my host is godaddy and linux server. and using version 4.0beta10 for sitem map.

    i am getting 404 error in webmaster tool and following when i check site map.

    XML Parsing Error: no element found
    Location: http://www.theindiapost.com/sitemap.xml
    Line Number 4, Column 1:
    ^

    Regards

    @balwinder Singh,

    It appears to be working fine. I’m getting no error when loading your sitemap.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Google XML Sitemaps] 4.0beta8 404 Error’ is closed to new replies.