WordPress.org

Forums

Google Plus One Button
+1 button do not show (14 posts)

  1. sijo55
    Member
    Posted 3 years ago #

    I have installed your plugin but the +1 button will not show.
    In admin area it is neither showing in button preview.

    http://wordpress.org/extend/plugins/google-plus-one-button/

  2. jeremyarntz
    Member
    Plugin Author

    Posted 3 years ago #

    What browser are you using? I just tested in IE 7 and the Preview does appear to be broken in IE 7.

  3. sijo55
    Member
    Posted 3 years ago #

    I am using IE9 but I have tested with FF 4.0.1 with same result..

  4. jeremyarntz
    Member
    Plugin Author

    Posted 3 years ago #

    Very odd I just tested it in FF 4.0.1 on my Mac and PC with no issue. Do you have the latest version of the plugin and have you tried clearing your cache?

  5. sijo55
    Member
    Posted 3 years ago #

    Can you try to look at this post on my site (Norwegian)
    The +1button should show between the post and the FB like button.
    http://www.xn--idyry-yua.no/iDyroy/?p=3661
    http://www.idyrøy.no/iDyroy/?p=3661

  6. sijo55
    Member
    Posted 3 years ago #

    And yes, I have the latest version and I have cleared the cache..

  7. jeremyarntz
    Member
    Plugin Author

    Posted 3 years ago #

    Ok so looking at your site in Chrome I see the button, but you're right in FF 4.0.1 nothing. If you look at my page http://jeremyarntz.com do you see the buttons?

    It looks like you have some javascript errors on the page. I'm wondering if something is conflicting with or preventing the Google +1 javascript from running.

  8. sijo55
    Member
    Posted 3 years ago #

    I can se the button on your site with both IE and FF.

  9. jeremyarntz
    Member
    Plugin Author

    Posted 3 years ago #

    Ok so there must be a conflict on your site because I'm using the exact same plugin version. As much as I'd prefer you to use my plugin, but if it was my site I'd try one of the other Google +1 plugins to see if the same issue is occurring. If so then I'd try deactivating / removing other plugins/ embedded javascript until I found the offending code.

  10. sijo55
    Member
    Posted 3 years ago #

    Ok, thanks. Will try to look at this tomorrow..

  11. sijo55
    Member
    Posted 3 years ago #

    Hi again..
    I searched the net and I did find this: (not tested yet)
    There's a few caveats:
    1. It's not available in IE. It will eventually be fully supported in IE8+. It'll just render an empty space in most unsupported browsers.
    2. A bug is currently preventing it from functioning in any page with a meta "generator" tag. This tag is totally without function otherwise, so if you're suffering from the problem feel free to delete the tag. Google is hoping to fix the bug in the next day or so. We'll keep you posted here.

    If you're on WordPress and have a spurious generator tag to remove, here's a simple hack:

    remove_action('wp_head', 'wp_generator');

  12. jeremyarntz
    Member
    Plugin Author

    Posted 3 years ago #

    Great find! I'll be away from the computer till tomorrow night, but I look forward to hearing if this works!

  13. sijo55
    Member
    Posted 3 years ago #

    No, this did not work.
    But I think there must be something else confusing the +1 button since your plugin is working fine on another site I have..

  14. mbquilts
    Member
    Posted 3 years ago #

    I can see and use the button in chrome and safari but not in firefox 5. There I can see it but it consistently returns an unknowable error.

    http://www.artsroundup.com/wp/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Plus One Button
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic