Support » Plugin: Google Maps made Simple » [Plugin: Google Maps made Simple] Maps aren't inserting or saving

  • I’ve been using this great plugin for a while now..

    I just updated to the latest version. Now it’s not saving the maps.

    There was one existing map in my database that was showing up under the “Map Library”, however, I wasn’t able to modify it. I tried deleting it and starting again, but no luck.

    I tried disabling the plug-in, re-enabling it, switching the “Save map information in your database” option. Still no luck.

    Also, all new maps are inserted with [wpgmappity id=”0″] instead of [wpgmappity id=”1″], which is how the first map was displayed in previous versions.

    I’m guessing this has to do with the recent update.. all the new features are cool, but if it doesn’t work, well… 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • BTW I’m using the most recent version of WordPress 3.1

    For anyone else having the same problem:

    I turned off the “Save data when disabling plugin” option on the plugin options page, disabled and deleted the plugin, re-installed and ever-thing’s working as advertised.

    Thanks for this great plugin and the all the new options!

    Plugin Author mschwar


    Hey danno – I’m the author.

    I’ve been hunting and hunting for the source of this problem and have been able to reproduce this error that some people are having with 0.5.5

    The solution you just posted makes perfect sense – by turning off the “save data” option the tables in your database were wiped when you deactivated and then built fresh when the new version was installed.

    This localizes the problem to the database update functions.

    If you see this could you fill in a couple blanks for me? It will really help me track down why some people are experiencing this problem.

    What version of the plugin were you previously on? If you don’t remember a specific version number, do you remember about when the last time you installed it / upgraded it was?

    What web hosting company are you using? Would you happen to know what PHP version and MySQL version you run?

    For anyone else reading – if you are having this same problem the answers to those questions would really help me stomp this bug.

    Hi Matthew,

    Thanks for the quick response. I also posted on your website, then I realized from the previous posts that this issue had been going for a bit..

    To fill in the blanks:

    I’m not positive which version I had installed previously. Initially, I think it was 0.4.4 (I installed it within the past two months). However, you released a bunch of updates over the past few days (weeks?). I ran each upgrade as it became available. I’m certain I didn’t make the jump from 0.4.4 to 0.5.5.

    Furthermore, I’m not sure at which point it broke.. The map I had in my database was working and I hadn’t needed to edit anything.

    I use Media Temple as my hosting provider. My PHP v. 5.2.14, MySQL v. 5.1.26

    I wish I could be more help.. It’s a really great plugin. Very user-friendly and with the new options, I don’t feel as compelled to jump into KML or the Google Maps API.

    I really appreciate all the hard work you put into this!

    Good luck and let me know if there’s anything else I can do to help..


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Google Maps made Simple] Maps aren't inserting or saving’ is closed to new replies.