WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Google Maps Embed] Trouble saving settings and language parameter feature request

[Plugin: Google Maps Embed] Trouble saving settings and language parameter feature request

  • jrf
    Participant

    @jrf

    L.S.,

    Another issue I ran in to:

    When I try to change settings through Settings->Google Maps, I get a

    You do not have sufficient permissions to access this page.

    message while I’m logged in as admin.
    Changed I made *are* however saved correctly.

    I’ve read somewhere that WP3 changed how admin priviledges is checked, so may be you could have a look at that.

    Additionally, the line underneath the map now always says View larger map. IMHO this should be a language parameter, but as it’s the only public one, I’d suggest making it a setting and allowing admins to change the text.

    Smile,
    Juliette

    http://wordpress.org/extend/plugins/google-maps-embed/

Viewing 2 replies - 1 through 2 (of 2 total)
  • jrf
    Participant

    @jrf

    I figured out where the problem lays, I just don’t know how to change it.

    In the options.php file, this is line 10:
    settings_fields( 'cets_embedGmaps-group' );

    This generates the following html code:
    <input type='hidden' name='option_page' value='cets_embedGmaps-group' /><input type="hidden" name="action" value="update" /><input type="hidden" id="_wpnonce" name="_wpnonce" value="7667fc0b85" /><input type="hidden" name="_wp_http_referer" value="/mydirectory/wp-admin/options-general.php?page=cets_embedGmaps_options?page=cets_embedGmaps_options" />

    As you can see, the page variable gets added twice to _wp_http_referer.
    name="_wp_http_referer" value="/mydirectory/wp-admin/options-general.php<strong>?page=cets_embedGmaps_options?page=cets_embedGmaps_options</strong>" />

    This is the cause of the insufficient permissions error.

    Hope you can fix it 😉

    Smile,
    Juliette

    jrf
    Participant

    @jrf

    I figured out where the problem lays, I just don’t know how to change it.

    In the options.php file, this is line 10:
    settings_fields( 'cets_embedGmaps-group' );

    This generates the following html code:
    <input type='hidden' name='option_page' value='cets_embedGmaps-group' /><input type="hidden" name="action" value="update" /><input type="hidden" id="_wpnonce" name="_wpnonce" value="7667fc0b85" /><input type="hidden" name="_wp_http_referer" value="/mydirectory/wp-admin/options-general.php?page=cets_embedGmaps_options?page=cets_embedGmaps_options" />

    As you can see, the page variable gets added twice to _wp_http_referer.
    name="_wp_http_referer" value="/mydirectory/wp-admin/options-general.php<strong>?page=cets_embedGmaps_options?page=cets_embedGmaps_options</strong>" />

    This is the cause of the insufficient permissions error.

    Hope you can fix it 😉

    Smile,
    Juliette

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Google Maps Embed] Trouble saving settings and language parameter feature request’ is closed to new replies.