[Plugin: Google Doc Embedder] Plug-in unable to retrieve the document (2 posts)

  1. mbarrio
    Posted 6 years ago #

    So I got the plug in workin and everything just fine. It rocks by the way. But when I tried to upload an actual company ppt it said that "Sorry, we are unable to retrieve the document for viewing.
    Please try again later."
    I tried again later and still no luck, tried with Chrome and FF but same story.

    Here is the link,
    Is the file just to large? It is 22 mb.
    Any help would be awesome!



  2. k3davis
    Posted 6 years ago #

    Hi Matt,

    I've spent some time troubleshooting this, and this is what I've found:

    There does apparently seem to be a file size restriction on the viewer. Unfortunately, I can't find documented what that is. However, there is no reason to have a 22MB powerpoint in this case. :)

    I tried it after downloading your file and compressing the photos inside, shrinking the document to just over 5MB with no loss of screen quality. After uploading it to a test location on my server, it works.

    What I did was select one of the images in your PowerPoint and on the pictures toolbar there is an option to "compress pictures". Using the "options" button on that dialog from PowerPoint 2007 (may be different in older versions) I set it to compress for screen use, all of the pictures in the document. Then I just saved over it. You can do this same thing to your current document, or just download the version from my test page above (which I'll remove shortly - just wanted to show you that it works). ;)

    You can find more info about reducing the size of your PowerPoint presentations here (Office XP/2003) or here (PowerPoint 2007).

    In the meantime though I will continue to try to find out what the maximum supported file size of the viewer is, because I was not aware of this limitation before. Thanks!

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic