WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
PDF Document Not Loading in IE8 (7 posts)

  1. Bellbird
    Member
    Posted 3 years ago #

    My embedded PDF document is not loading in Internet Explorer (IE8). It loads OK in Firefox and Chrome.

    I have tried with Enhanced Viewer. This generates the following error:

    Notice: Undefined variable: curl ... /plugins/google-document-embedder/proxy.php on line 32

    in all browsers.

    Switching to Google Standard Viewer resolves this error in Firefox and Chrome, but not in Internet Explorer. In Internet Explorer a "loading bar" is displayed but only a icon indicating that the file was not loaded is displayed. I have tried several PDF documents and several WordPress pages. Here is an example of my code:
    [gview file="http://www.mydomain.com.au/wp-content/uploads/2010/10/Test-2-PDF-Document.pdf"]

    Clicking on the "Open in New Window" icon in the Google Doc Embedder Toolbar opens the PDF document in doc.google.com. Reloading the page with the embedded PDF file in Internet Explorer now loads the missing document. However if I go to second computer that has never loaded the page before I still have the same problem in IE - the PDF document does not load.

    I have tried editing/re-saving the page and clearing the IE cache, but can't duplicate the problem once the document has loaded once at doc.google.com. Creating a new page with a new PDF also loads correctly in IE on the first computer, but not on the second.

    This problem is currently preventing me from using this otherwise excellent plugin as it is performing unreliably. Any help would be appreciated.

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    bellbird,

    Is it possible you could send me the entire error message (not truncated "...") or a link to the page where it's displayed?

    Try using the integrated plugin editor to change the following line in proxy.php, and let me know what your results are (line 32):

    if ($curl) {

    change to:

    if (isset($curl)) {

    This problem doesn't effect most environments, and I can't reproduce it myself, so it will need a little troubleshooting help from you to solve. Thanks.

  3. Bellbird
    Member
    Posted 3 years ago #

    Hi k3davis

    Here is a link to the file:
    http://www.callaghansmarine.com.au/index.php/about-us/test-pdf-embed/
    Password protected page. Password is: bellbird.

    I have edited proxy.php as suggested. Here are the results:

    In Google Standard View mode the embedded PDF document does not load.

    In Enhanced Viewer mode the page generates the following Javascript error and the document page stops loading with the Loading bar at about 1/4 complete.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.5; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
    Timestamp: Thu, 14 Oct 2010 22:16:52 UTC

    Message: Syntax error
    Line: 1
    Char: 1
    Code: 0
    URI: http://www.callaghansmarine.com.au/wp-content/plugins/google-document-embedder/proxy.php?jsfile=gview/resources_gview/client/js/1357654511-gview_local_gview_base_mod__en_gb.js

    Message: Object expected
    Line: 595
    Char: 9
    Code: 0
    URI: http://www.callaghansmarine.com.au/wp-content/plugins/google-document-embedder/proxy.php?url=http%3A%2F%2Fwww.callaghansmarine.com.au%2Fwp-content%2Fuploads%2F2010%2F10%2FTest-PDF-Document1.pdf&hl=en_GB&gdet=&embedded=true

    Message: 'gviewApp' is null or not an object
    Line: 617
    Char: 9
    Code: 0
    URI: http://www.callaghansmarine.com.au/wp-content/plugins/google-document-embedder/proxy.php?url=http%3A%2F%2Fwww.callaghansmarine.com.au%2Fwp-content%2Fuploads%2F2010%2F10%2FTest-PDF-Document1.pdf&hl=en_GB&gdet=&embedded=true

    Message: 'gviewApp' is null or not an object
    Line: 719
    Char: 13
    Code: 0
    URI: http://www.callaghansmarine.com.au/wp-content/plugins/google-document-embedder/proxy.php?url=http%3A%2F%2Fwww.callaghansmarine.com.au%2Fwp-content%2Fuploads%2F2010%2F10%2FTest-PDF-Document1.pdf&hl=en_GB&gdet=&embedded=true

    Happy to assist with troubleshooting. Please let me know what to try next.

  4. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Bellbird,

    With your current settings, your document loads for me as expected in Firefox 4b6 and in IE8 on Windows 7/64-bit.

    In Google Standard View, IE won't work under hardly any circumstance; this is a known issue with Google's viewer that my enhanced viewer was meant to combat, and appears to be working on your site (I see the "Test PDF Document" PDF loading correctly in both of the environments above).

  5. Bellbird
    Member
    Posted 3 years ago #

    Even though you can't duplicate the problem it is still occuring in Enhanced Viewer mode in some environments - like mine and my clients. Therefore we cannot be sure which website visitors can see the document and which cannot. Obviously we can't use the plugin in this condition. What to do next?

  6. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    Bellbird, I will continue thinking about it, but please understand that if I can't see the problem, I can't fix it. If you can help me provide an environment that consistently causes the problem (even if it's on a platform or web browser I don't currently have) I will do my best to investigate the matter. I know "it works for me" is the worst technical support one can receive, but literally I can't fix a problem that even on your own site does not manifest itself to me.

  7. brieric
    Member
    Posted 3 years ago #

    This is a simple fix:

    Go into the proxy.php file, go to line 32 where it shows
    if ($curl) {

    and change this to
    if (isset($curl)) {

    PHP doesn't allow checking of existing variables the previous way anymore.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic