WordPress.org

Forums

Google Doc Embedder
[resolved] Not able to find document error (5 posts)

  1. gwhitney3
    Member
    Posted 3 years ago #

    I'm running GDE on the BP Mag theme with BuddyPress. I'm receiving the error:

    Sorry, we were unable to find the document at the original source. Verify that the document still exists.
    You can also try to download the original document by clicking here.

    I've tried a few combinations but I'm currently configured in the simplest for troubleshooting. My blog is running on IIS 7.5 on a private (non-Internet accessible) server. For testing, I upload a DOC file to the media library of my site. I get the URL for that DOC and I put it in my address bar and I can access the file. When I plug that URL into the GDE configuration I get the loading bar and then the error message above. However, if I click the "here" link in the error message or the document link outside of the object window provided by the plugin then I am prompted to download the document. This means that IIS is locating and serving the doc.

    I can't determine why GDE is not rendering the document. I've tried this with a couple of different documents.

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. beredim
    Member
    Posted 3 years ago #

    My blog is running on IIS 7.5 on a private (non-Internet accessible) server

    If this is true for the .doc files too (not Internet accessible) then of course they won't display, because Google Docs Viewer cannot access them.

  3. yuriconalc
    Member
    Posted 3 years ago #

    I'm getting quite frustrated with GDE. The PDF works just fine if I put in a direct link, it's right where it's supposed to be, but GDE Embed keeps saying it can't find it or load it.

    Is it the size of the PDF? It's 58Mb, and Google docs only seems to handle smaller media well.

  4. k3davis
    Member
    Plugin Author

    Posted 3 years ago #

    @gwhitney3 - beredim is correct; while you may run GDE on a private instance of WordPress, the embedded document itself must be somewhere publicly accessible (see Notes, #2). Also mentioned in the FAQ here on wordpress.org.

    @yuriconalc - I'm sorry for your frustration; most certainly the issue is the size of your PDF as you stated. Please see the same page (Notes, #3). You can use Acrobat to reduce the PDF file size, or perhaps optimize the PDF at its source document (for example, compress the images in Word).

    Hope this helps.

  5. gwhitney3
    Member
    Posted 3 years ago #

    Yes, lack of logic on my part. Thanks for the plugin and the support.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Doc Embedder
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic