Support » Plugins » [Plugin: Google Doc Embedder] NGG Conflict

Viewing 5 replies - 1 through 5 (of 5 total)
  • Scott, I was able to reproduce this error and will investigate it as soon as possible. Thanks for the report; I’ll post back with an update.

    Scott Winterroth

    (@countrymusicchicago)

    Great. As always, thanks k3davis!

    Scott,

    This is a bizarre error. I can’t for the life of me figure out why clicking on a link in NGG (“edit thumb”) is causing WP to evaluate anything in my plugin at all. I looked at the source code in the relevant portion of NGG but I don’t know enough about AJAX to understand what it’s trying to do or why it may be causing a conflict.

    The error is in the add_action(“plugins_loaded”) hook itself. The actual functions this action refers to don’t matter; even if I comment them out entirely the error occurs. The documentation on this action is scant but the way I’m using it seems consistent with the way others use it, so I’m at a loss.

    The error does not seem to interfere with the function of either plugin, so I’m not going to mess with anything until I understand the problem better. However if the message bugs you, you can bypass it by turning off plugin conflict checking in GDE “advanced options”.

    If a more advanced programmer can give me any feedback or ideas about this error, or how the plugins_loaded action works across multiple plugins, I’d be grateful.

    Thanks,
    Kevin

    Hi,

    I experience the same error as Scott, but with another (fatal) error that prevents me from uploading images with NGG. When I disable GDE, NGG runs fine.

    Here is what I get :

    Disable plugin conflict warnings unchecked :

    * browser : ERROR HTTP ERROR : IMG_7560.JPG : 500
    * logs :

    PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'gde_conflict_check' not found or invalid function name in /var/www/wordpress/wp-includes/plugin.php on line 395
    PHP Fatal error:  Call to undefined function gde_t() in /var/www/wordpress/wp-content/plugins/google-document-embedder/gviewer.php on line 173

    Disable plugin conflict warnings checked :

    * browser : ERROR IO FAILURE : IMG_7560.JPG : Error #2038
    * logs :

    PHP Fatal error:  Call to undefined function gde_t() in /var/www/wordpress/wp-content/plugins/google-document-embedder/gviewer.php on line 173

    My GDE is version 1.9.6 under WP 3.0.1 with MU activated.

    Thanks for any clue !

    The issue with NGG and the function gde_t is known. Unfortunately, it seems to be one that needs to be addressed on the NGG side. I’ve tried versions of my plugin that rename this function, comment its content out completely, etc. and NGG will still fuss with it. Historically this hasn’t kept either plugin from working, though the error is unsightly. If it is indeed broken now, a change in NGG must have made the situation worse.

    I regret that I have no solution to offer you. I’ve tried everything I can think of on GDE’s end to work around this issue without success, so I must refer you to the author(s) of NGG for a possible solution.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Google Doc Embedder] NGG Conflict’ is closed to new replies.