WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Google Doc Embedder] GDE EMBED ERROR: invalid URL, please use fully qualified URL - resolve (12 posts)

  1. rondepping
    Member
    Posted 4 years ago #

    I was getting the dreaded
    <!-- GDE EMBED ERROR: invalid URL, please use fully qualified URL -->
    error on some urls that worked fine in a browser.
    After scratching my head from a while I noticed a pattern. If the url has underscores then I would get the error. I escaped the underscores and then it works fine.
    Example:
    http://www.vmware.com/pdf/vsphere4/r40/vsp_40_admin_guide.pdf - generated an error
    http://www.vmware.com/pdf/vsphere4/r40/vsp\_40\_admin\_guide.pdf - worked!

    You might want to note that or fix it in a future version.
    Thanks for the plugin it comes in very handy!

  2. k3davis
    Member
    Posted 4 years ago #

    Thanks for reporting this. I have struggled a good amount to find a regular expression that matches most URLs. Every so often I find I have overlooked one.

    I will work on correcting this, but in the meantime rather than escaping those underscores, you can add force=1 to the shortcode. That will bypass the internal file tests for that particular instance. That way, it won't break again when the fixed comes out, I hope!

    I appreciate you going through the trouble of finding the pattern and reporting it; that is very helpful.

  3. k3davis
    Member
    Posted 4 years ago #

    Hmmm... curious. I'm not getting that error when I try to use the same URL on my own server.

    http://davismetro.com/gde/test/

    There must be something else going on besides the regex causing the problem, perhaps a php.ini setting? I'll keep investigating.

  4. rondepping
    Member
    Posted 4 years ago #

    Yes strange that it works for you without the escapes.

    I'm running WP 2.8.5 with Apache/2.2.8 (Ubuntu) mod_python/3.3.1 Python/2.5.2 PHP/5.2.4-2ubuntu5.6 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8

    WP 2.8.5 is using the UTF-8 charset and en-US language settings.

    When I put the force=1 in I get this error: <!-- GDE EMBED ERROR: cURL not installed, bypassing checks -->
    and a sorry we can not generate your document at this time message appears in the viewer.

    escaping the url makes it work even with the force=1 option.

  5. k3davis
    Member
    Posted 4 years ago #

    Is it possible for you to send me the URL of the page you're calling this from? If you don't want to do so publicly, you can send it via the support form on the plugin site.

    It's really curious that you get the cURL error and that the viewer can't find the file when you use force=1. Underscores aren't even characters that PHP needs to escape. I'm wondering what the embed code looks like in your page source when you have force=1 turned on and the URL as it's supposed to be (without the escaped underscores). If the viewer loads and can't find the file, the path is being altered somewhere along the way I can't yet explain.

    I don't want to ask you to go out of your way to help me figure this out, but if you have the time to work with me on it I'd really appreciate it, since I can't reproduce the error myself.

  6. rondepping
    Member
    Posted 4 years ago #

    Unfortuately I'm running this behind a firewall. - I'll capture the html source and send it to you via the support form.

  7. rondepping
    Member
    Posted 4 years ago #

    Ok I played around a little more and I'm seeing this happening.

    something is changing anything from /vsp_put what ever you want_xxx to /vsp< em >put whatever you want< /em >xxx. ( My spaces to let it show up in the forum.) Looks like a filter to change anything inbetween the underscores to emphsis if preceded by /vsp. Very strange.....

  8. rondepping
    Member
    Posted 4 years ago #

    Ok a little more digging and it looks like anything between 2 underscores get converted. The _'s is replaced with < em > and < /em >

  9. rondepping
    Member
    Posted 4 years ago #

    FOUND IT!!!!!!

    The Markdown Plugin was modifying the text in the editor. It was replacing anything between underscore with emphsis tags.

    Sorry to have lead you on a wild goose chase.

  10. k3davis
    Member
    Posted 4 years ago #

    Hopefully the author of that plugin can modify it to ignore code within shorttags? Thanks for posting your findings here!

  11. davidyoo
    Member
    Posted 4 years ago #

    I'm having the having issue. Here is the URL and the error message.

    http://yorbalindasda.org/backoffice/wp-content/uploads/2009/12/Rental-Contract-with-Church-of-Grace.pdf

    <!-- GDE EMBED ERROR: invalid URL, please use fully qualified URL

    Any ideas?

  12. k3davis
    Member
    Posted 4 years ago #

    hi davidyoo,

    I tested this on my site and this URL worked correctly as expected. I am guessing there may be a conflict with another plugin you have installed? If you would be willing to send me a list of the active plugins (and versions, if not all current) on this site via the support form I would like to test this more thoroughly.

    In the meantime if you check the box in GDE Options under Advanced Settings to "Let Google Docs Viewer handle all errors" the viewer will load bypassing all error checking internal to the program. This is not to say it will definitely work given your configuration, but it might help. If you want this only for the current document, you can add force=1 to the shortcode for this instance.

Topic Closed

This topic has been closed to new replies.

About this Topic