Support » Plugin: Google Doc Embedder » [Plugin: Google Doc Embedder] GDE displays "Moved Temporarily"

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author k3davis


    I suspect this has something to do with the document having multiple spaces in the name. Can you rename the file replacing the spaces with underscores or hyphens, and see if the problem persists?

    The plugin normally works around this circumstance, but in the source URL the spaces are being encoded as %2520 instead of %20. I can’t explain that behavior, as that’s not what the plugin is programmed to do; it appears to be something being done on your server’s end. But it’s worth a try to see if that’s the source of the issue or if it’s merely a false guess.


    I just created a test page and this is the iframe section:

    <iframe src="" class="gde-frame" style="width:100%; height:800px; border: none;" scrolling="no"></iframe>

    and still the same issue.

    This problem is relatively recent, I’ve had months of use without problem.

    Plugin Author k3davis


    That’s very puzzling, but thanks for bearing with me as we try to sort out what the issue is, since I’ve not run into it anywhere else. Do you have the same issue if you use the Standard Viewer option?

    Plugin Author k3davis


    If this issue still presents after updating to 2.2.3 (fixes some other enhanced viewer issues), please email me directly. I’d like to test out some other proxy.php changes in your environment, since I can’t reproduce the issue in mine.

    You can use the support form linked from your plugin list, or the email address in the license portion of the gviewer.php file.


    Hi, i’ve got the same issue – the plugin was working fine until it began to missing the files. It’s like this now:

    Could you please give me some advices? Thanks a lot!


    I have add the same issue. I run WP MS 3.3.1. Does anyone else have this issue on ms or is it plugin related. Love this plugin, hope someone figures this one out! M

    Plugin Author k3davis


    I have an another attempted fix for this. I know the issue is with Google Docs Viewer and not with my plugin, because I’ve seen it on other sites that embed the viewer directly, even apart from WordPress. But I haven’t nailed down the exact cause.

    The file at this link tries to assist by adding a bit of code that may bypass the redirect. I need people willing to test it out and let me know, since I don’t have this issue on my installs. The change is minimal and should be safe, but I nonetheless urge you not to try this in a mission critical, production environment. If a problem occurs, you can reinstall the plugin from the repository to the release version.

    1. Go to the plugin editor in the WordPress list, and choose Google Doc Embedder.

    2. Open up the gviewer.php file for editing.

    3. In another window/tab, go to this URL and copy the contents to your clipboard:

    4. Paste the content over the top of the current content of gviewer.php within WordPress. Save the file.

    5. Try your document again and see if the redirect is still present. You may need to clear your browser cache first.

    6. Let me know the results!

    If someone is unable to follow these instructions and wants a full install via email of the plugin with this patch for testing purposes, please let me know.


    Hi, I am sorry for reporting about it changed nothing. It is still “moved” as on the above link… Anyway, thank you for your help!

    Plugin Author k3davis


    @mishari, I see that the problem is no longer visible on your site. Daniel, I no longer see the plugin on the link you provided. I’m wondering if this problem was resolved (on Google’s end). Can anyone provide a URL that still causes the issue?


    @k3davis it seems that when I switched my web host, the problem went away. The issue seems to be somehow related to the host I was using.

    Best regards

    Nice plugin, I like it! Just writing to give you a feedback: unfortunately I have the same problem… I will keep the plugin on my list and in case you guys figure out the problem (I wasn’t able to), and release an update addressing it, I will probably start using it! All the best 🙂

    I’ve made a fix on the sites I own. I had the message as everyone above, but the actual link that it was saying the file had moved to was simply httpS.

    I edited the proxy.php plugin file and replace all HTTP with HTTPS and it works great now.

    This must be something Google changed to force all docs to be viewed in HTTPS mode?

    Plugin Author k3davis



    Thanks for the tip. I’ll test it out and if it doesn’t break anything I’ll roll it into the next update. I was never able to reproduce the problem on my site so it was shooting in the dark to try to fix it.

    Plugin Author k3davis


    I rolled this change (with a few tweaks based on testing) into the just released version 2.4. I would love it if someone who has this issue could upgrade to the latest release and let me know if the problem has been addressed.


    I just updated our site and took a look. I’m getting this message within the iFrame now.

    Fatal error: Cannot redeclare curl_get_contents() (previously declared in /<Path to install>/wp-content/plugins/google-document-embedder/proxy.php:133) in /<Path to install>/wp-content/plugins/google-document-embedder/proxy.php on line 144

    Any help to you?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Google Doc Embedder] GDE displays "Moved Temporarily"’ is closed to new replies.