The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] [Plugin: Google Doc Embedder] Fleeting success, now GDE EMBED ERROR: invalid URL, please use fully q (4 posts)

  1. ersavla
    Posted 6 years ago #

    I'm just dreading the inevitable dope-slap user error that this must be, but wonder if you could lend that particular dope slap, k3davis (or anyone else):

    I did succeed once in getting a PPT, uploaded via the Media Library, to embed. After some other modification to the post however, the file fails to show. The source code reflects this error:

    <!-- GDE EMBED ERROR: invalid URL, please use fully qualified URL -->.

    I've replicated what I believe to be same exact steps I used that first time, and it still won't show. (I've tried in other posts. Tried restoring to the working version, etc., etc.)

    I am using (and have validated) the File URL offered via the Media Library, e.g.,


    Any clue or hints?

    FYI: Looks like someone else might have been trying to find similar help: http://wordpress.org/support/topic/316417?replies=2

    Many thanks.


  2. k3davis
    Posted 6 years ago #

    hi ersalva,

    Your shortcode syntax is incorrect. Try this:

    [gview file="http://digitalinnovation.icexconnect.com/files/2009/09/EASlides.ppt"]

    Note the file= attribute.

    Let me know if this does not resolve the issue for you. Please see the FAQ or the plug-in web site for more information about the plugin's accepted shortcode attributes.

    Also - thanks for linking to the other person's problem, I had missed that.

  3. ersavla
    Posted 6 years ago #

    UGH. I *knew* I was missing something blindingly obvious, despite having read the FAQs. Thank you very much for the prompt reply to a dopey problem.

    The plug-in is a key find for a client-facing proof of concept, so I thank you much for your work.

  4. k3davis
    Posted 6 years ago #

    Honestly, I spent about 20 minutes troubleshooting it before I noticed myself ;) And it led me to improve the error checking on that particular point in 1.7.1, so don't consider it a "blindly obvious" error at all. It helped me make the plug-in better.

    Glad it is helpful to you!

Topic Closed

This topic has been closed to new replies.

About this Topic