Support » Plugins » [Plugin: Google Doc Embedder] Embedder is stuck on “loading”

  • Resolved Jwerta12


    Plugin was working great, now it seems to have trouble loading on the page.

    When i click on any of the pages with the embedder it won’t load successfully. There are no error messages, and I believe I have all code correctly in place.

    here’s one example:

    Here’s’ is the shortcode im using:
    [gview file=””]

    File is there, if i go to url I can download, and download link still works as well on page. I can see the menu bar for the viewer, and the frame but it shows the loading bar stuck at about 25%.

    Is this some error on my end, with the plugin, or googles??

    any help would be very much appreciative.


Viewing 7 replies - 1 through 7 (of 7 total)
  • I went to google docs viewers page:

    and entered the document’s url to generate a link:

    It generated a link and when i clicked to view it I receive this message on google:
    “Sorry we are unable to generate a view of the document at this time. Please try again later”

    Does this indicate that is something on google’s end?

    Still be digging around on google’s forums.

    did following troubleshooting:
    -cleared cache/cookies – still not working
    -re-uploaded original pdf file – was able to successfully generate link and view through “”

    Then i went back to original page i posted and it also successfully loaded. However, the other pages i have same code on for different pdfs still do not successfully load. I re-loaded a few others as well and it has fixed problem 50% of time.

    looks like i found a possible solution, but it sure is a pain to have to reload pdfs to site….any clue on why these might stop loading after a few views??


    page is again not loading. was fixed for a minute but back to original problem. i believe this error is on google’s side…

    any advice would be very helpful.



    I’m not able to reproduce this problem (the code you entered is working fine on my end, on first load and several refreshes):

    It also appears to be loading fine for me on your own web site, at the link you provided.

    Maybe it is a temporary issue between google and your ISP? If the link above also results in a hang, I would suspect so.

    Let me know what you discover, but I don’t think this is an issue with the plug-in.

    Hi jwerta12,

    I’ve the same problem. When I click on “open in new window” it works and when i go back to original page i posted it loads also successfully.

    Have you resolved the problem ?

    Problem solved for me. I decided to hide some functions on the toolbar.
    I’ve changed this and the plug-in works correctly.

    john-l, good catch; I am able to reproduce this problem now and will try to get a fix posted. In the meantime I’d encourage you not to use the toolbar hide options as you suggested.

    Upon further testing I see that the custom toolbar options irreparably cause this problem. I had only tested the options against files already present in cache, which was insufficient (obviously), so what appeared to work in fact did not. I’ve removed these options from 1.7.2 but will see if it can’t be reimplemented somehow in the future. At first glance, it appears that code within the Google Docs Viewer itself prevents this from working properly, so this may not be possible.

    Sorry for misleading and for unknowingly releasing the plug-in with an inadequately tested feature. This is my first plug-in, so live and learn (for me) but I regret any inconvenience caused.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Google Doc Embedder] Embedder is stuck on “loading”’ is closed to new replies.