Support » Plugins » [Plugin: Google Doc Embedder] Embedded PDF not displaying in FF 3.5.6

  • Resolved scn095


    I’m building a site and can’t get GDE to display my PDF documents reliably in Firefox 3.5.6. It works fine with IE8 once I made the appropriate setting change.

    Firefox shows the viewer’s frame, but inside the frame is the graphic for a broken link to a media item. (Actually, I found one time that page 2 was visible if I scrolled down, but page 1 wasn’t. Now neither pages are visible.)
    The PDF is in my uploaded Media; not Google Docs, so it’s public. I’ve triple-checked the URL and deleted and replaced the uploaded file multiple times with brand-new PDFs.

    The GDE options settings I’ve changed are:

    • Un-checked “Display the download link by default”
    • Checked”Let Google Doc Viewer handle all errors (for individual files, use force=’1′”

Viewing 3 replies - 1 through 3 (of 3 total)
  • scn095


    I had an idea to try viewing the site with FF in Safe Mode, with my add-ons and custom preferences disabled.
    Didn’t help…
    This time, the “Loading” progress bar was visible in FF for about 5 seconds (I don’t recall seeing it before; my documents are short) and then the broken link to media item was displayed for both pages again.
    Check out one of the posts I’m having trouble with.

    I thought it could be the applications I’m using to create the PDFs, so I’ve tried Bullzip PDF Printer, doPDF 7.0.321 and Primo PDF, the latest versions of all (I don’t have access to Acrobat Distiller).
    Again, the PDFs by all creators display just fine in IE8 with the appropriate setting change made, but not in FF 3.5.6 even with add-ons and custom preferences disabled (no “Loading” progress bar is shown in IE8, either).

    At first I thought that it could be a conflict with other plugins I have installed, but then why would IE8 work fine?

    Here is the list of my activated plugins:
    Atropos 1.1
    cforms 10.5 (not the latest version)
    Cron GUI 1.01
    Custom Excerpts 1.0.4
    Global Translator 1.2.7
    Google Doc Embedder 1.9.2
    Google XML Sitemaps 3.2.2
    Lightbox 2 2.8.2
    MapPress Easy Google Maps
    NextGEN Gallery 1.4.3
    Page Links To 2.1
    Raw HTML capability 1.2.5
    Role Manager 2.2.3
    Secure WordPress 0.5
    Snow, balloons and more 0.9.2
    Thumbnail For Excerpts 2.1
    TinyMCE Advanced 3.2.7
    WP-Mail-SMTP 0.8.2



    hi scn095,

    This may be as simple as a browser cache issue? When I click on the link you provided there to illustrate the problem, the entire document loads normally on my end. Certainly the PDF is fine then.

    That said I have seen this behavior in the viewer before at random times, where page 1 is broken and page 2 etc. load properly. It seems to be a quirk with Google’s viewer but I can’t consistently reproduce it (as I can the IE8 issue). I would start with clearing your browser cache, or perhaps giving it a try from another computer, just to verify there isn’t some local issue with your machine.

    Let me know what you find out!




    Thank you for being so responsive.

    Your reply inspired me to try something that I had thought of briefly, but had forgotten: create a new FF profile.
    And guess what… it seems to have worked, by Jove.
    Even though I have FF deleting everything but cookies (including the cache) when I close it, some lagging gremlin in the profile appears to have been the problem.

    Thank you again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Google Doc Embedder] Embedded PDF not displaying in FF 3.5.6’ is closed to new replies.