WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Google Doc Embedder] Background image of pdf not showing

[Resolved] [Plugin: Google Doc Embedder] Background image of pdf not showing

  • i have a pdf file that uses a custom background image for copyright purposes. in other words, the background functions as a watermark. however, it is not displaying correctly in GDE no matter what browser I am using. The background just turns to white, which is unfortunately, the color of the text in the pdf, making the whole document non-readable.

    can anybody help me?

    http://wordpress.org/extend/plugins/google-document-embedder/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author k3davis
    Member

    @k3davis

    Try it out from Google Viewer directly – it could be that it does not support watermark feature. I have never tried this.

    https://docs.google.com/viewer

    Hi k3davis!

    It doesn’t work on Google Viewer as well.

    What’s funny is that it works on my local machine using my local copy of wordpress (the links point to the online version of the pdf).

    Plugin Author k3davis
    Member

    @k3davis

    Could you send a screenshot or two of what you’re talking about? Perhaps I’m not understanding the issue. You can find my email address in the GPL statement of gviewer.php.

    Thanks!

    Hi Kevin!

    I sent you an email with two png file attachments (screenshots).

    Let me know if you need anything else.

    Thanks!

    Hi Kevin!

    I think I have found out what’s causing the problem. GDE seems to be having a problem displaying protected PDF files properly, regardless of whether you’re using 40-bit or 128-bit encryption. When I remove the PDF file’s security settings, it gets displayed properly. Is there a way to tweak the plugin’s settings to make it display secured PDF files correctly?

    i found a solution. it has something to do with how the pdf files were created. using a texture as a background image was the culprit. had to go back to ms word, remove the texture, put it back in as a watermark and then export it to pdf.

    that did the trick!

    Plugin Author k3davis
    Member

    @k3davis

    Hi there,

    Thanks for letting me know what you discovered the issue to be. I’m sorry for my slow response as I was away from email for some time due to an unexpected emergency.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Google Doc Embedder] Background image of pdf not showing’ is closed to new replies.