WordPress.org

Forums

Google Analytics Popular Posts
Fatal error - help please (10 posts)

  1. gpsman
    Member
    Posted 3 years ago #

    When activated the widget displays a Fatal error the first portion of which I copied below:

    Fatal error: Uncaught exception 'Exception' with message 'GAPI: Failed to request report data. Error: "User does not have permission to access profile 476005."' in /usr/local/4admin/apache/vhosts/actionnow.net/addon/gpsman.com/blog/wp-content/plugins/google-analytics-popular-posts/gapi.class.php:218 Stack trace: #0 ...

    Any suggestions welcome.
    JAC

    http://wordpress.org/extend/plugins/google-analytics-popular-posts/

  2. koichiyaima
    Member
    Plugin Author

    Posted 3 years ago #

    Hi gpsman,
    Lets do it “again” from the beginning.
    1). Please fill the Username field with the email address you use to login to your Google Analytics.
    2). Please fill password correct too again.
    3). check for your Profile ID.
    (UA-xxxxxxx-xx is not the Profile ID, The profile ID of your account can be found in the URL of your reports. For example, if you select a profile from an account and view your reports, you may see a URL string that looks like this:
    https://www.google.com/analytics/reporting/?reset=1&id=123456&pdr=00000000-00000000

    The profile ID is the number that comes right after the &id parameter. So, in this case, your profile ID would be 123456.)

    Thanks for your post.

  3. gpsman
    Member
    Posted 3 years ago #

    Thank you for the advice. Changing the account number made the error message go away.

    However, now there are two errors occurring. All the links have the same name. In this case they are all labeled "An Easter Blessing" each with a different link. The second problem is the link addresses are malformed at two places. My site is located under the directory "/blog" but the links in the widget all have it twice: "/blog/blog" a directory that doesn't exist. Additionally, each link ends with the file name "index.html". The correct page will load if the "index.html" is eliminated.

    Could this have something to do with the filter? I don't have anything entered in that box. Anything I put there that wasn't the default resulted in a verbose error report on the page.

    Thanks,
    JAC

  4. koichiyaima
    Member
    Plugin Author

    Posted 3 years ago #

    Hi gpsman,

    1) All the links have the same name.
    2) Link addresses are malformed at two places.

    If you are using proxy to connect to the internet. Google Analytics don’t like that!

    I see a URL in your error message that looks like this:
    http://usr/local/4admin/apache/vhosts/actionnow.net/addon/gpsman.com

    But, your web site URL is http://www.gpsman.com.

    If each with a different URL, its Post ID can not get it, then
    "Google Analytics Popular Posts" does not work.

    Thanks for reporting it.

  5. koichiyaima
    Member
    Plugin Author

    Posted 3 years ago #

    I added the site URL input field.
    Please enter your site URL of Google Analytics into the input field.

  6. gpsman
    Member
    Posted 3 years ago #

    Version 1.0.7 almost works. The address in the link seems to work if I trim the "index.html" text off the end.

    Also this version shows the relative address instead of the page title in the link button.

    I will leave it enabled for a while in case you want to look at
    JAC

  7. koichiyaima
    Member
    Plugin Author

    Posted 3 years ago #

    Hi gpsman,

    Don't afraid.
    If you have the MySQL server on local, For security, the post ID can not get from outside.
    In this case, specification of "Google Analytics Popular Posts" is displayed the relative address.

    Thanks for your advice.

  8. gpsman
    Member
    Posted 3 years ago #

    I haven't changed any MySQL settings and previously a title was being displayed instead of the address.
    More important is the fact that the link address includes "index.html" which will not work. If "index.html" is not part of the address it does work.

    Thank you,
    JAC

  9. koichiyaima
    Member
    Plugin Author

    Posted 3 years ago #

    I saw your site. And I understood.
    "index.html" It contains all the links.

    I'll try to check whether a specification of Google or other.

  10. Julian Magnone
    Member
    Posted 3 years ago #

    Ok, I found this. Seems Google Analytics has been updated and now it doesn't use ID in the URL. So this is obsolete.

    What I did to fix this is. Open Google Analytics HTML source code and look for the string containing something like this:

    [{"id":"a296721w16477197p17298424","name":"www.....

    Now. locate p17698224 and remove the prefix "p" from the string. So, the profile ID that you need to enter is "17298424" in this case.

    Hope this helps. I will write a post explaining this in my blog http://weblatam.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics Popular Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic