Support » Fixing WordPress » [Plugin: Google Analytics for WordPress] wp_footer not called

  • I have installed the plug in for google analytics from http://yoast.com/wordpress/google-analytics/ and added code correctly my uA tracking ID
    The help page states in faqs
    I’m logged out and I still don’t see the tag code on my posts or pages?
    Check whether your theme calls wp_footer(); in footer.php, if it doesn’t, add it

    Have looked at footer.php and wp_footer is not called
    Cam sks please give me the exact line of code I should add to footer.php

    Mnay thanks in advance

Viewing 15 replies - 1 through 15 (of 21 total)
  • Add this before the </body> tag (and any analytics code) in your footer.php:

    <?php wp_footer(); ?>

    thanks iridiax
    that seems to have resolved it

    jackiecooperwriter

    (@jackiecooperwriter)

    Hello
    please can you help me? I have gone through all this and still don’t see any google analytics code anywhere.
    I have gone into the theme editor and put <?php wp_footer(); ?> ahead of whatever code is in this file. There is no <body> tag in the code in this file.
    I tested the page and still saw the footer appear as it had before.
    Then I pasted in the google analytics code between the <?php wp_footer(); ? and the rest of the code in this file. The footer still looked the same and I don’t see any google analytics code anywhere.
    I am stuck – what do I do? I don’t know html and I’m not sure where to go from here.

    Jonathan Stegall

    (@jonathanstegall)

    You need to make sure that the file you are editing is called “footer.php”. If the file does not have </body>, do not add the wp_footer code. A WordPress theme is made up of many files, some that contain HTML and some that do not.

    A good footer.php will end like this:

    <?php wp_footer(); ?>
    </body>
    </html>

    This should work nicely for you, if you modify the correct file.

    Thanks Johathan

    Still not working for me. I have a correct footer.php but I don’t see the code anywhere. I’m using a static front page (page_home.php) that displays the WP-Cumulus plugin by Roy Tanck which displays a tag-cloud.

    Just updated to v2.8. Seems to work now!

    Hi –

    I just installed this plug in and my footer code looks correct, but I don’t see anything, even when I log out as admin. Frankly, I’m really new at this and am not sure what I’m supposed to be seeing. But the footer looks exactly the same.

    Any suggestions?

    Thank you,
    Jennifer

    Please update to reflect these options for wp_footer…

    http://codex.wordpress.org/Theme_Development

    wp_footer
    Goes in the “footer” of a theme; footer.php template. Example plugin use: insert PHP code that needs to run after everything else, at the bottom of the footer.

    Usage: <?php do_action(‘wp_footer’); ?>
    -or- <?php wp_footer(); ?>

    Just upgraded this plugin and am getting:

    Warning wp_footer(); not found in your footer.php file, this might mean this plugin will not work!

    I have <?php do_action(‘wp_footer’); ?> in my footer.php file just before the <body> tag.

    What is the problem? Do I need to change <?php do_action(‘wp_footer’); ?> to <?php wp_footer(); ?> or will this break the theme??

    Please let me know – this plugin has been working great up to now.

    Thanks

    I’ve been using the last version for a month now without any problem. I updated to the new version tonight like everybody else here. Now I also receive the same warning sign.

    Could it be that my footer.php is called Footer.php with a capital letter. If not there is a bug with the new version.

    Thanks for your time

    Jean-Marc

    I met the same problem as you did. I am using the theme “inove” for my blog, and I found that footer.php of this theme has 1 line as below:

    <?php include(‘templates/end.php’); ?>

    I open the end.php and found it do has the codes like this:

    <?php wp_footer(); ?>
    </body>
    </html>

    So I just copy the content of end.php to replace the line”<?php include(‘templates/end.php’); ?>” in footer.php, and the problem is solved.

    Thanks iridiax.

    The trick worked for me and I’m using
    WordPress 2.8
    Yoast 2.9.3

    Pali Madra

    I am relatively new to WordPress and am also having the same problem with this plugin. I use WordPress 2.8 and have deleted and reinstalled the plugin. I have made sure that the necessary code in in the footer.php including my code in the brackets and that it is in the correct place in footer.php but I am still getting the same message on the plugin page that ‘Warning wp_footer(); not found in your footer.php file, this might mean this plugin will not work!’
    I am using the Grow your Business Theme and am at a complete loss to know what else to do.

    Hi everyone,

    Here is the content of my “footer.php” file’s content:

    <div class=”footer”>
    <div class=”fr”>Designed by 110Words InfoZoft</div>
    <div class=”fl”>Copyright © 2008 · “><?php bloginfo(‘name’); ?></div>
    </div>

    Where should I put the above lines please?

    Thanks and Regards,

    Yilmaz Cesur.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Google Analytics for WordPress] wp_footer not called’ is closed to new replies.