Google Analytics by Yoast
[Plugin: Google Analytics for WordPress] Won't authenticate with Google Analytics. (40 posts)

  1. Rob Roy
    Posted 3 years ago #

    WordPress version: 3.4.1 Multisite Network
    WordPress SEO version: 4.2.4

    I did this: Activate plugin, go to Google Analytics under Settings. Click here to authenticate with Google, Grant Access

    I expected the plugin to do this: Bounce back to WordPress and ask which site I'd like to track.

    Instead it did this: Unfortunately, an error occurred while connecting to Google, please try again: Re-authenticate with Google


  2. waynmeyer
    Posted 3 years ago #

    Hey ive just had the same problem.

    However i could almost put my problem out there as i know what caused it, just need help to fix it. What i did was delete my old admin user and created a new one. Once the original admin account was deleted thats when the analytics stopped working. Now i need to know how to fix it. It was great while it lasted, its a perfect plugin, however i think its google. Google Analyticator is the best plugin with great results. please help us fix this problem, im about to go live :(

  3. Andrew Ledwith
    Posted 3 years ago #

    I had the same problem, though it was not caused by the scenario described by waynmeyer. Thanks for your help.

  4. rajc007
    Posted 3 years ago #

    I'm having the same problem with just one of my wp sites.

  5. andrewjstein
    Posted 3 years ago #

    I get an error that says something about "insufficient permission"

    It get's worse. With the recent update, I went in and checked everything, to find that Google Analytics has stopped showing any data since May 22, of this year. I've been relying on this plug-in, and with the summer, didn't review my Google Analytics - but was incredibly prolific. No numbers to show for it?

    now, with the last update, I can't fix the problem (won't authenticate), and I have no tracking data since May.

    Yea, I read the support pages.., and manual authentication doesn't work either. Something bad happened. Any ideas? I have no way to know what happened in May, either.

  6. andrewjstein
    Posted 3 years ago #

    In looking at the google analytics admin page, this message is displayed.

    "Tracking Not InstalledLast checked: Sep 1, 2012 10:27:24 AM PDT
    The Google Analytics tracking code has not been detected on your website's home page. For Analytics to function, you or your web administrator must add the code to each page of your website."

    I've manually authenticated..., several times over the past few weeks. Clearly something is not working..., could be user error - I'm open to that. Need any guidance experts can offer.

  7. Theolobias
    Posted 3 years ago #

    Same problem with my wp-installation - I already documented it here: http://wordpress.org/support/topic/plugin-google-analytics-for-wordpress-authentication-with-google - since I never had this issue before, I guess it must have something to do with the plugin's recent update.

  8. waynmeyer
    Posted 3 years ago #

    Hey everyone

    I'm still having the same problem, however I believe it was for the better. I recently just decided to do without the plugin. Here's what I did that works 100x better.

    Firstly I should mention that I believe it's the google auth problem rather then the plugin. What should work is to flush out the plugin from your database table. Always backup if you going to try this. Simply login to your server host and use php my admin to find that database table from the plugin, then reinstall and activate as normal see if that works. Clear the cache while you at it.

    I was going to do the above until I played with google analytics and decided that there is way better results there. People forget that the actual core of every plugin has better features "standard" and free. So I decided to link that up to. My iPhone app analytics pro. Now I'm way better off as I can watch my analytics on the go. I instantly fell inlove with the instant results on the go that I've never looked back.

    Any other experiences in finding and alternative would be great to share.

  9. andrewjstein
    Posted 3 years ago #

    OK, any more ideas from the wizards..., I need help. I just "inspected" the home page html for my site, and the google analytics code is inserted in 3 places, so the message from GA is incorrect. It just isn't detecting my key.


  10. waynmeyer
    Posted 3 years ago #

    Hi Andrew

    Did you try the database trick? Flush out the old and start fresh?

  11. gauravsr
    Posted 3 years ago #

    I am getting "Invalid Token" when I click on button "Click here to authenticate with Google."

  12. graydog
    Posted 3 years ago #

    I try to install google analytics for word press and try to activate and get error:

    The application that directed you here claims to be "Google Analytics for WordPress by Yoast". We are unable to verify this claim as the application runs on your computer, as opposed to a website. We recommend you deny access unless you trust the application.

    How do you FIX IT? Please Help!

    (http://www.whatattractsmentowomen.org) Thank You ....Charlie

  13. andrewjstein
    Posted 3 years ago #

    Hi Waynmeyer,
    I'm a little uneasy with the "flush database" approach. Probably over my head. Sure would be good to have Yoast comment here..., this seems to be a bigger issue with the last few updates not "updating" cleanly.

    I'll try the uninstall, and reinstall..., but now I'm cosidering just dropping the plug-in. I see several other forums are suggesting that's the better route. Inserting the std. asynch code in the footer that Google tells you to do may not give the granularity that Yoast's plug-in is supposed to deliver, but at least that works - by other's accounts.

    FWIW, folks, I always wait til I have a support issue before sending plug-in developers' a paypal donation. If the support is good, then I'm all over a 3figure donation to a developer that produces both a great plug-in and good service and support. This one, with all the hype, is not going in the right direction. ...best to vote with your wallet. ;-]

    I would rather not give up - if someone could at least identify the problem, and point to a solution - even if it is coming in a future revision from Yoast. Communication is key.

  14. matthew@dreamcell.co.uk
    Posted 3 years ago #

    I have a batch of sites using this plugin, and suddenly the Dashboard widget isn't working on ANY of them. Most are still feeding traffic back to GA, but you need to visit GA to see the results. So having read through the above and being short for time, I have to say that I think Google must be at fault here - or that this fantastic plug-in hasn't kept up. Our developer, on who we all rely, isn't a lively correspondent! Positively taciturn.

  15. andrewjstein
    Posted 3 years ago #


    I don't know..., I spent about 12 hours the past two days, and think that the issue is either a bug, or has to do with "caching"..., Plug-ins often cache so they don't have to regenerate common code from the DB. That would be an obvious thing to do here. And, if the updates yoast puts out don't "clear the cache" as part of the install process, then the changes to the plug-in don't apply. This could be due to an install bug, or could be a glitch in the update for a number of reasons.

    What is needed, like what is found in well developed performance-based caching plug-ins (nice list of these found at: http://j.mp/OMJzPN), is a button to clear the plug-in's cache, manually, and rebuild from the database the yoast content for the header/footers. THAT would be a nice plug-in feature. [Or even an idea for a standalone plug-in that selectively cleared cache for plugins that misbehave.]

    I've found a few other leads, and checked all those. And, there seems to be a "_utm.gif" call missing from the Yoast code, at least in my site - I learned about this on the Google Developer Analytics site. http://j.mp/REwt7f . Assuming I read it right - which it is entirely possible that I did not!.

    I'm not coder, so I can only read what it says, and it indicates in debugging, that there needs to be this call, with two parameters - also missing...

    I like Yoast's stuff, but I can't feel good about paypal'ing donations to a developer that doesn't respond. And, his Bit.Ly plugin has never worked for me, or a dozen of my friends..., I gave up on that one.

    We're all fallable ;-] I'm continuing my search for answers.

  16. andrewjstein
    Posted 3 years ago #

    For others reading this thread, I did find another data point that indicated that google tracking fails if you have a naked domain name (one without the "www." The issue, if you configure google analytics' profiles for the name with "www." in front of your domain, and it should not be..., (IF your domain is a naked one...) then GA will fail, as it considers naked domains different than ones with the "WWW." in front of them.

    I'm not the expert here - please refer to the site where I found this: http://j.mp/OhBiUI for the full story.

    FWIW, I found that I had this issue - and ensured that I had every location in my database to use the naked domain name, that means in every place in SEttings, and such, and even at my host, under the cpanel, ... as well as the multiple places you have to have it in your GA settings, I put all the same domain syntax.

    Alas, that has not fixed this for me - but it has eliminated that issue as one variable.

    I am putting this here in hope that this helps someone.

  17. andrewjstein
    Posted 3 years ago #

    NEW GA Google Analytics Not Tracking PROBLEM FIXED...

    OK, for anyone still following this thread, here is what I have found, and what appears to have FIXED the problem.

    Go to ADMIN (in the upper right corner of your GA account, - new interface).

    Click on "Filters" tab. If you have a filter, get rid of it. I'm no GA expert, and am absolutely certain that I did not put a "filter" in this tab of any kind. But, best as I can figure out, when the new GA interface rolled out, someone defaulted this Filter to follow "your website only"..., but unfortunately, that website filter filters OUT everything.

    Again, I don't know why, all I know is that I found a very vague reference to this on the GA forum at Google: https://productforums.google.com/forum/#!category-topic/analytics/discuss-tracking-and-implementation-issues/jA_X3W9ZBxM
    Whic a tech named Whims suggested "Don't ever apply a filter to your main reporting profile"...

    Why was there one there? I dunno - it was put there by Google in the roll-out of the new GA.

    I suspect that all the folks on these and other forums that had this "change" suddenly happen to them between Feb and Jun of 2012, as the new GA rolled out, have this same issue.

    If this fixes it for you - please post here so others can learn from what you know.

    If you know how, and what to do with Filters..., that's a good topic to share too!..

  18. waynmeyer
    Posted 3 years ago #

    Thank you for sharing andrew, i will try it sometime this week and report back. You never give up do you lol.

  19. John
    Posted 3 years ago #

    No filters on my end. Besides, I'm not getting to the point where I can even select an analytics site.

    This is the error I get when I try to authenticate with another analytics plug:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site "http://yoursite.com" has not been registered.

  20. bitoolean
    Posted 3 years ago #

    I have no filters set either and I had to manually specify the UA code.

  21. Cecilia Svensson
    Posted 3 years ago #

    Hi all,

    I´ve been using the plug in Google Analytics for WordPress a bit over a year. Working just fine.
    Recently I opened up a new domain re-rounting viewers to my webb site. I want to track the traffic with Analytics for my new site.

    In Google Analytics for WordPress Configuration page I pressed th button Re-authenticate with google and got the error described in the first post of this thread.

    I can enter one UA-code manually, but that´s it.
    What I want is to be able to follow two UA codes.

    Previously I could choose Profile and UA code and it sure looked like it would be possible to enter more than one UAs since it was a drop-down list in that field.

    I use Google Analytics for WordPress version 4.2.5.

    The new domain I talked about is ceciliasvensson.se
    and the one I´ve had over a year is vaja.se.

    What I want is to be able to add two UA codes in the plug-in.

    /Cecilia Svensson

  22. andrewjstein
    Posted 3 years ago #

    I found a very knowledgable person, named "Whims" on the Google GA forum. you can get there via this link, which is where a list of common tracking set-up mistakes is listed.


    Get into the support forum where Whims hangs out, and where I found my answer to this thread, at: http://productforums.google.com/forum/#!topic/analytics/jA_X3W9ZBxM

    Wouldn't it be great if these two forums had some kind of collaborative link ! ;-)

    Someday, it will happen. Disruptive innovation on its way.

  23. thesocialdiner
    Posted 3 years ago #

    Not Working for me either. Don't have filters, don't want to do the db purge method. Will just manually adding the UA code work ?

  24. jodyangel
    Posted 3 years ago #

    ...but you can't Get the UA code until it authenticates.

  25. jodyangel
    Posted 3 years ago #

    I see No filters anywhere..

  26. SiteSubscribe
    Posted 3 years ago #

    Same problem. Single WP install.

    Opened different browser and the plugin refuses to authenticate even though I'm logged into Gmail on another tab.

    "Unfortunately, an error occurred while connecting to Google, please try again"

  27. thesocialdiner
    Posted 3 years ago #

    I looked at another account I had as well, and currently it works as the screen shots (Help files, etc from Yoast) suggest. Though when I try to re-authenticate that same page that appears to be working, then fails. So I have to hit the back button , then save the profile to return to the working mode.

    It's looking like either the WordPress updates, or the Plugin updates have failed in it's most recent iteration. Is this forum the only place to get support if we're not a donating member of the plug-in ?

  28. andrewjstein
    Posted 3 years ago #

    @thesocialdiner - I agree with you, the trouble seems to be something in the update. Either the Plug-in update, or the new GA interface (rolled out between Feb and June of this year, best I can tell)

    OR a combination of both.

    @jodyangel The filters tab is tricky to get to. Click on "ADMIN" in the upper right, on the orange menu bar, in Google Analytics. You should see a page with tabs on it. the fourth tab should say "Filters". Click that, and if you have filters, they may be filtering out all activity to track. When the new GA interface installed, for me May 22, a filter filtering the entire website I had configured popped up. No way did I do that !..., Anyway, deleting that, fixed it for me. To delete it, you highlight it (I think) then the right side of the selection will show a "Remove" as active, and you pick that, and poof !

    Good luck.

  29. JakeBondo
    Posted 3 years ago #

    Are there any alternatives to this plug-in? I have used this yoast plug-in for sometime, but I cannot get it to work on a new site.

  30. Arevico
    Posted 3 years ago #

    you can try mine, btw it shouldn't be possible to authenticate via your blog. A server application for the google api shouldn't b distributed and a javascript implementation requires the url to be whitelisted. The author cant know which urls the plugin is getting installed on, so he can't white list hundreds of sites

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.