Support » Plugins » [Plugin: Google Analytics for WordPress] Unable to save GA settings, form resets

  • I have tried several times now to enter my GA-code in the form, but pressing te Update Google Analytics Settings replaces my code with ‘1’, and resets all other settings too (like checks the ‘track administrator…’- checkbox.
    Latest update of WP and of GA for WP-plugin. Suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • I am having the same problem. I tried deleting the plugin completely, removing it from my server, and completely downloading and re-installing a fresh copy.

    Hopefully, someone has a fix!

    Are either of you using WP 2.7.* rather than 2.8.*?

    I have 4 blogs where this is working fine, but one which still uses 2.7 because of theme upgrading issues I’m still working on and I can’t get updates to stick for the 2.7 blog.

    There are also some display issues where parts of the display show things like:

    <tt>checked=”checked” checked=”checked” checked=”checked” checked=”checked”</tt>

    I checked the required version of WP listed on the plugin site and it says 2.7 should be OK.

    I am having the same issue and experience. Additionally at the bottom of my admin pages I am getting the error:

    Warning: call_user_func_array(): First argumented is expected to be a valid callback, ‘ga_admin::success’ was given in /client/home/wordpress/docs/wp-includes/plugin.php on line 339

    I am using Worpress 2.8.4.

    Same issue for me. Just upgraded a site from 2.3 to 2.8.4. Upgraded the GA for WP plug-in. Tried de-activating, deleting the plug-in, downloading from the developers website, re-activating etc – same behavior.

    I have another site that I just checked that’s been running 2.8.4 and I just noticed that it has the same message “Google Analytics settings reset to default” and the Analytics Account ID: says “1”.

    I did a quick check in the MySql database for the string that holds the Google Analytics settings. It’s inside of the “wp-options” table, and under the “option_name” of “GoogleAnalyticsPP”. All the settings are there. And are not deleted when reseting Google Analytics settings.

    Any advice?

    I have figured out a solution!

    Simply delete the record from the MySql database. This seems to allow Google Analytics to rewrite your settings.

    Of course, editing your MySql database is a bit harder than it sounds, but a quick google search will reveal some results!

    Good luck!

    I’ve also done some further investigation. I also checked the MySQL database wp-options table, GoogleAnalyticsPP record. I found all of the original settings (prior to the plug-in upgrade) still stored there including the UA tracking number even though the Google Analytics UA tracking number wouldn’t show up in the Dashboard User Interface (settings->google anlaytics). I checked my Google Analytics reports and they all continued to collect data properly after the upgrade.

    I think this is a bug in the Form (the User Interface) display only. It appears that after an upgrade (in certain situations) the user interface will display the UA tracking code as a “1” and display all the other options as though they are reset, even though the entries in the database are correct and reporting continues uninterrupted. I also thought about deleting the record from the database to force a new re-write which Shayzorblade noted above.

    I had the same problem, having upgraded to wp 2.8.4, and upgrading the Analytics plugin immediately afterwards.

    Shayzorblade’s solution worked for me too (thanks!) — deleting the GoogleAnalyticsPP record from the wp-options table, then saving the new options using the form.

    @rcmillion Thanks, you helped me a lot.

    I disabled the plugin. I looked up the GoogleAnalyticsPP in the wp-options table, deleted it. Reactivated the plugin and was able to save my settings. Thanks again!

    I’ve tried the solution here to no avail. The user interface/settings page for the plugin always says

    “Google Analytics settings reset to default.”

    Also, since this problem started, I’ve had zero visits recorded by GA for the past week.

    Does anyone have any idea how to fix this problem? Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Google Analytics for WordPress] Unable to save GA settings, form resets’ is closed to new replies.