Support » Plugin: Google Analytics for WordPress by MonsterInsights » [Plugin: Google Analytics for WordPress] Plugin conflict due to bad code

  • I mentioned this to you on Twitter, but your plugin is being a bad neighbour. 🙂

    On line 841, you’re checking if oauth_token is set, however you’re not checking if you’re actually on the Google Analytics page. If another plugin (say, mine) uses an OAuth postback correctly, it will be overriden by this.

    GA_Admin::authenticate() should be checking if it’s actually on the GA page.

    Thanks. 🙂

    http://wordpress.org/extend/plugins/google-analytics-for-wordpress/

  • The topic ‘[Plugin: Google Analytics for WordPress] Plugin conflict due to bad code’ is closed to new replies.