Support » Plugin: Google Analytics for WordPress by MonsterInsights » [Plugin: Google Analytics for WordPress] Issue with In Page Analytics

  • Using 4.2.2 of GA for WP. I tried to use the ‘colour bubbles’ option on in page analytics and get the following error message:
    “We’ve identified problems in your setup. These may cause problems loading In-Page Analytics.
    Your site doesn’t load ga.js from Google. If you host the Google tracking code on your own servers, it isn’t updated automatically and can miss important changes.
    We didn’t find a tracking snippet on your site. In-Page Analytics cannot load. Please make sure you have tracking installed correctly. If your snippet is included in a separate JavaScript file, you’ll have to manually check it is being loaded correctly.”
    The code snippet is installed and all other data is being tracked. I have not selected the option to use ga.js locally.
    This happens on all sites where I use GA for WP. It does not happen on sites where I manually add the tracking code or use a different plugin

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same thing happens to me.

    “Your site doesn’t load ga.js from Google. If you host the Google tracking code on your own servers, it isn’t updated automatically and can miss important changes.”

    Could be the cache?


    I have used this plugin on 2 sites. One with a cache plugin and one without.
    The one with no cache plugin works fine while the other doesn’t.
    However when I deactivate the cache plugin and clear the cache it still gives me the error maesage.

    Any suggestions would be helpful.


    Same issue here.

    Same with me?
    Please notify if someone has got the solution.

    same for me..:(

    I am getting the same error – I tried checking the box for “Host ga.js locally:” and specifying the link but the same error occurs.

    Looking at the plugin code, (line 1066) the google version is indeed the default set to be called ..

    if ( $options['gajslocalhosting'] && !empty($options['gajsurl']) ) {
    	echo "'".$options['gajsurl']."';";
    } else {
    	$script = 'ga.js';
    	if ( current_user_can('manage_options') && $options['debug'] )
    		$script = 'u/ga_debug.js';
    	echo "('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '".$script."';";

    in the same way as displayed in the google example script. So I’m guessing this error is a red herring and something else is going on. Yoast? Help?


    A ha! I was logged into my site as administrator and had the option set to ‘Ignore Users: Administrator’ .. Which means ga.js is not loaded. So when I opened up the site in the in page analytics tool, it was loading the logged in version. I logged out and immediately saw the stats I was looking for.

    Hope this helps someone else,

    Hey! how did you change this “‘Ignore Users: Administrator'”?



    I have tried with the “ignore users: administrator” checked and unchecked and logged in and out and am STILL having this problem! (it’s under advanced settings)

    It’s kind of a big issue. Any help would be greatly appreciated!



    Also tried several “tricks”, but nothing has been resolved yet? A new message entered the GA/In-Page Analytics window: Problem loading In-Page Analytics: We tried looking for a few common problems with your setup, but couldn’t find what’s wrong. Please try again later.
    Found a script on web which told me, that the GA javascript could interfere with each other, if the ga.js was represented more then once in your site. IN this case I’ve installed/activated both GA and G-Analyticator which has worked fine all the time. I’ve tried to deactivate the G-Analyticator and now I only see the ga.js once, namely in the footer file region. Now I have to wait for the next 24 hours when GA is generating new data from site.
    Try using your developertools in Firefox or G_Chrome. And find in “view source” if the ga.js is represented more then once on site? It is a known issue, that the .js will interfere with each other! Best regards Andy

    Hi! G_Analyticator has to be activated during the usage of GA! Activated G_Analyticator again, but this time I’ve only ga.js represented once in the footer region, where it is supposed to be!
    So something has changed, but what it really leads to…I haven’ t discovered yet. The error message in GA is still present within In-Page etc…., bst rgs Andy

    Just found out what’s going on. I have NoScript and DoNotTrackPlus that block the ga.js script. Once I allowed the script to run on my own website, the error went away.


    DoNotTrackPlus was my problem too.
    The error is gone. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Google Analytics for WordPress] Issue with In Page Analytics’ is closed to new replies.