Support » Plugin: Google Analytics for WordPress by MonsterInsights » [Plugin: Google Analytics for WordPress] 4.2 gives fatal error while activating

  • Hi there,

    I’ve just updates my Google Analytics plugin By Yoast to the latest version. I get a fatal php error when I try to activated it again:
    Fatal error: Cannot redeclare class OAuthException in /home/jonassmets/domains/ on line 8

    I’ve go no knowledge about php so i’ve no idea to solve this.
    Before this I was running the previous latest version… I haven’t changed a thing to my wordpress setup so I don’t think it has anything to do with this.

    Hope someone could help?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hi,

    I have the same Probleme.

    Waht’s the solution ? We need to modify anything in the file OAuthException

    Thanks for your help


    Same issue with me.

    Blog still runs but I cannot access the admin area.

    Fatal error: Cannot redeclare class OAuthException in . . . . ./blog/wp-content/plugins/google-analytics-for-wordpress/wp-gdata/OAuth.php on line 8

    Same here because Simple Twitter Connect uses also OAuth.

    Fatal error: Cannot redeclare class OAuthSignatureMethod_HMAC_SHA1 in (…)/wp-content/plugins/simple-twitter-connect/OAuth.php on line 82

    I solved the problem reverting back to older Google Analytics for WordPress plugin version


    How do you revert back if you can no longer get into the admin panel?

    I had the same issue chonazz. As for your issue pcsservices, what I did was remove the “google-analytics-for-wordpress” plugin folder using FTP. Do you have FTP access to your site? If not, you should set it up, it comes in handy for many instances, including things like this.

    Otherwise, you can revert to your site backup if you run regular backups.

    Hey Drunkard – that worked. Thanks

    Guess I will revert back to the previous version.

    Hi Folks,

    On all three of my sites, even after removing, or manually updating the plugin by FTP, I get this error when trying to get to the admin pages:

    “Not Found

    Sorry, but you are looking for something that isn’t here.”

    Have also disabled all the plugins by myPHPAdmin … but no joy.

    Something, somewhere has become corrupted … any hints on what it may be?


    Deleting and restoring the database does not help either.



    Same problem…………………
    This is classing with the Twit connect plugin on my site

    We’re working on a fix, the twit connect plugin is coded crap because it doesn’t check whether a class already exists, so it’s actually their bug, but I’ll work around it.

    Well, you obviously don’t check if the class exist either…

    I solved the OAuthException issue by renaming it GA_OAuthException, this is only a temporary solution because this could happen with another class depending on the plugins you run.

    Good solution. I did the same thing. As soon as a new version of the plugin is released, it’s safe to just upgrade and overwrite.

    Understand the concern about other plugins not following good practice. Since it’s basically impossible to enforce that, maybe the best thing is to name plugin classes with odd prefixes. 🙂

    AFAIK prefixing functions and classes with the plugin’s name is what’s recommended

    I get another fatal error message :

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /homez.309/roughdre/www/wp-content/plugins/google-analytics-for-wordpress/wp-gdata/wp-gdata.php on line 14

    what should I do ?

    fanny-g: you’re on PHP4, get with the program and make sure you’re running PHP5.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Google Analytics for WordPress] 4.2 gives fatal error while activating’ is closed to new replies.