Support » Plugin: Google Analyticator » [Plugin: Google Analyticator] Widget Errors and Blank White Page on Settings Screen

Viewing 15 replies - 16 through 30 (of 33 total)
  • Is that a setting within the plugin? Is there some way that I can enabled the error reporting, as I am currently unable to access the plugin’s settings … or do I need to wait for your update?

    Here is some info on how to turn on WP_DEBUG for testing purposes

    http://codex.wordpress.org/WP_DEBUG

    Ben

    Okay, these are the notices displaying on the Settings page for the plugin:

    Notice: Use of undefined constant WORDBOOKER_SETTINGS – assumed ‘WORDBOOKER_SETTINGS’ in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/wordbooker/wordbooker.php on line 174

    Notice: Trying to get property of non-object in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/wordbooker/wordbooker.php on line 2761

    Notice: Trying to get property of non-object in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/wordbooker/wordbooker.php on line 2762

    Notice: Trying to get property of non-object in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/wordbooker/wordbooker.php on line 2761

    Notice: Trying to get property of non-object in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/wordbooker/wordbooker.php on line 2762

    Notice: Undefined index: meta in /var/www/vhosts/thesounddaily.com/httpdocs/wp-includes/class-wp-admin-bar.php on line 108

    Google Analytics logging is:
    Google Analytics UID:

    Fatal error: Cannot redeclare class URI_Template_Parser in /var/www/vhosts/thesounddaily.com/httpdocs/wp-content/plugins/google-analyticator/google-api-php-client/src/external/URITemplateParser.php on line 30

    Thanks – it looks like you have another Google plugin running that is also using a common class. We’ll wrap ours in an if statement to prevent the re-declare error.

    Ben

    Woot! I just LOVE those plugin conflicts … 😉

    Updated to 6.3.1 and I now have no way of editing any of my widgets, ( The whole of the right hand side of the widget screen is blank) besides the issue of white screen on GA.

    FireFox, Latest WP and Suffusion Them current version

    Happy to turn WP_DEBUG on if it will help.

    Oh, makes life SOOOO Easy!

    thanks for reporting the bug so we can fix it up.

    Just pushing up an update. Hopefully will fix

    Ben

    This is showing in the Dashboard GA Summary:

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error fetching OAuth2 access token, message: ‘invalid_grant” in /home/cheapest/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:113 Stack trace: #0 /home/cheapest/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/Google_Client.php(131): Google_OAuth2->authenticate(Array, ‘1/J6JLTZI9BVy57…’) #1 /home/cheapest/public_html/wp-content/plugins/google-analyticator/class.analytics.stats.php(68): Google_Client->authenticate(‘1/J6JLTZI9BVy57…’) #2 /home/cheapest/public_html/wp-content/plugins/google-analyticator/google-analytics-summary-widget.php(188): GoogleAnalyticsStats->checkLogin() #3 /home/cheapest/public_html/wp-content/plugins/google-analyticator/google-analytics-summary-widget.php(104): GoogleAnalyticsSummary->getAnalyticsAccount() #4 /home/cheapest/public_html/wp-includes/plugin.php(403): GoogleAnalyticsSummary->ajaxWidget(”) #5 /home/cheapest/public_html/wp-admin/admin in /home/cheapest/public_html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 113

    Hi Peter, have you tried resetting the authentication and doing again? And you are using the correct google sign in that your analyticts accounts are connected to

    Cheers

    Hi Ben

    I deleted the plugin and did a fresh install.
    Goggle returns to me a token to paste into the application.
    Currently there is no place available to complete the authentication.

    I too noticed the Error fetching OAuth2 access token.
    Google sign is correct

    Sorry….

    Hi, Just pushing up the 6.3.2 – if you update, we’ve turned off the Javascript based show/hide function, so you should be able to paste in the Auth code Google gives back!

    Let me know how you get on.

    Ben

    Works on another of my sites using Firefox so you guys rock!

    Updated to: 6.3.2:

    After pasting the code:
    Google Analytics UID: shows:>

    There was an Analytics API service error 400:Error fetching OAuth2 access token, message: ‘invalid_grant

    The drop down menu option attached to the GA Code text box isn’t showing… but it did fix the vanishing widget issue.

    😉

    Cool. I’ll be sitting on my admin for a while, so I’ll let you know how things go as soon as the pushed update shows up for me (it’s not there yet).

    Just updated to 6.3.2. It’s working perfectly now. I got my settings page back, AND the dashboard widget works now (it didn’t work for me in 6.2.x).

    I’m thrilled! Thanks for your quick attention on this. =D

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘[Plugin: Google Analyticator] Widget Errors and Blank White Page on Settings Screen’ is closed to new replies.