WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Google Analyticator] V 6.3.4 messes up widget area

[Resolved] [Plugin: Google Analyticator] V 6.3.4 messes up widget area

  • Bet Hannon

    @bethannon1

    Support Team Volunteer Wrangler

    Another bug: I updated to Version 6.3.4 yesterday, and a good portion of the widget page disappeared! Here’s a snip of that page.
    http://neillsvilleucc.org/files/2012/09/Widget-issue.jpg

    I know that GA is the problem, since deactivating GA restores the widget area to normal.

    This seems to be affecting all my multisite install sites, but not my single install sites. All the affected sites display this error message in the dashboard module:

    Fatal error: Uncaught exception ‘Google_AuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘{ “error” : “invalid_grant” }” in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php:279 Stack trace: #0 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(239): Google_OAuth2->refreshTokenRequest(Array) #1 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php(216): Google_OAuth2->refreshToken(‘1/MB7oZ6BdBvoyI…’) #2 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/service/Google_ServiceResource.php(166): Google_OAuth2->sign(Object(Google_HttpRequest)) #3 /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google in /nfs/c08/h04/mnt/123041/domains/churchwebsiteprogram.com/html/wp-content/plugins/google-analyticator/google-api-php-client/src/auth/Google_OAuth2.php on line 279

    I’ve tried resetting, but no help. Suggestions?

    http://wordpress.org/extend/plugins/google-analyticator/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Bet Hannon

    @bethannon1

    Support Team Volunteer Wrangler

    Curious: there are 40+ sites in my multisite, and I just discovered that some of them are NOT having this issue with the OAuth2 token & widgets….

    Moderator Bet Hannon

    @bethannon1

    Support Team Volunteer Wrangler

    On the sites that ARE affected, if I try a reset, I get through the Google authorization (code copied & pasted) just fine, but near the area where I should choose the property from my GA account, I get this error:

    There was an Analytics API service error 403: Error calling GET https://www.googleapis.com/analytics/v3/management/accounts/~all/webproperties: (403) User does not have permission to perform this operation

    Video User Manuals

    @videousermanuals

    Hi bethannon1

    when the Google popup asks you to sign in / grant access – are you logged into the correct Google / Gmail Account? Sometimes easy to sign in with the wrong Google account if you’re already signed in.

    Video User Manuals

    @videousermanuals

    Also, what Version of WordPress MU are you running?

    Moderator Bet Hannon

    @bethannon1

    Support Team Volunteer Wrangler

    I think the wrong google account might have been the issue….getting all sites re-authorized now, but so far no problems.

    Thanks! Sometimes the problem is user-error! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] [Plugin: Google Analyticator] V 6.3.4 messes up widget area’ is closed to new replies.