Support » Plugins » [Plugin: Google Analyticator] Request: show dashboard summary according to profile id, not UA-code

  • [Plugin: Google Analyticator]


    If several profiles have the same UA, last one (alphabetically?) is always shown on dashboard summary.


    Summary on WP dashboard is based on UA code, not profile id. There might be several profiles under the same UA-code.

    For instance, I’ve got two profiles under one UA-code, my main profile and another one with Google Website Optimizer (GWO) data. The one with GWO data is alphabetically lower than the main one, so it is being shown on Google Analytics summary in WP dashboard. However, I don’t always run GWO, so there are times the profile doesn’t gather any data (results in zero visits).

    Suggested solution:

    Show dashboard summary according to profile id which can be set in plugin settings.

Viewing 15 replies - 1 through 15 (of 20 total)
  • First off, thank you for taking the time to research the problem and come up with a proposed solution.

    This will be corrected in the next released version (hopefully next week). I will make sure that when saving the settings, the profile id is also stored with the UA UID.

    You can follow development on Twitter at to see when this correction makes it into the development version.

    There’s no rush. The problem can be avoided by renaming profiles.

    Thanks for an awesome plugin!

    Have you noticed a problem where the field to enter the UID disappears after the Settings page is loaded? It appears for about a second then disappears and I can’t enter the UID at all!

    Sounds like you’re experiencing the same problem another user reported here:

    There are a few suggestions in that thread that you’ll want to try (if any work, please let me know what worked).

    The next release will have a workaround that will prevent the box from disappearing if this situation occurs and you’re unable to authenticate.

    I can authenticate no problem. I just can’t enter a UID. When will this be fixed? It’s a bit of a hassle, I use this plugin on every WordPress site I create.

    Well, if you authenticate, you should receive a drop-down list to select your account, not a UID box. Are you not seeing that drop-down? If you are not, have you tried the memory limit increase suggestions found in the FAQ?

    Since you mentioned multiple sites, is this occurring on every website you run? Are they all on the same webhost or server?

    Additionally, is this a problem that just started with a recent upgrade? The box being replaced by a drop-down has been like that for a least a few months. What’s the last released version that worked fine for you?

    My others are fine and are all upgraded to the most recent release. I only noticed it because I went to install this on a new site I’m creating for a client and it won’t allow me to put in the UID.

    Well, like I mentioned in my previous reply, have you tried the memory limit increases?

    That’s a PITA. I am not getting any “Allowed memory size of xxxxxx bytes exhausted” errors as the link to the memory thing says you will. Not to sure why a brand new site with nothing else on the hosting account would have memory issues in the first place. The site isn’t live yet. Never had this issue until now. I run 7 WordPress sites off of my own hosting and this never happened.

    I understand this is a new server, but issues like this can still occur with a new server. In fact, a memory limit issue is more likely to occur on a new server if it’s been misconfigured.

    It’s not that you’re running out of memory, it’s that a cap has been imposed on how much memory can be used in a single page load. Furthermore, if error reporting is disabled, you would never see the “Allowed memory” limit message and would instead receive a blank page (exactly what is being sent to the settings page instead of a UID or drop down box).

    You seem pretty confident that it’s not a memory limit issue, but you would you mind just humoring me and increasing the memory limit to 128M temporarily? If it doesn’t make a difference, fine. We can cross that off the list, and look at a another potential source (on the contrary, if it does work, decrease the value by 16M until you find the lowest you can go without the error occurring). I’ve had a number of people report similar issues that have been fixed by increasing the memory limit, so I just want to verify the memory limit increase has been attempted before looking for other solutions.

    Just checking back if you’ve solved the issue. I would love to resolve this problem for you and anyone else who experiences it, but I can’t without your help.

    If you don’t want to try the memory limit increase, send me an email at I’d be happy to take a look at the problem on your server and work to develop a solution.

    That is not the problem as I have stated. Changing the memory limit did nothing.

    Thank you for reporting back. At this point, I think taking a look at the WordPress install in question is the best course of action. I don’t know off hand what would be causing the disappearing UID box.

    If you’re comfortable with it, having FTP access to the google-analyticator directory and a WordPress account with access to Google Analyticator’s settings on the affected server would allow me to troubleshoot the problem. A fix could then be developed that would benefit both yourself and anyone else experiencing this issue.

    If you’re okay with this, contact me at and we’ll talk.

    Could you attempt to correct the problem on a 2.9 install on your own server?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: Google Analyticator] Request: show dashboard summary according to profile id, not UA-code’ is closed to new replies.